Ontape --- out of disk space
Posted in 1999
Topics: Backup & Restore, Storage & Space Management, Error Codes & Troubleshooting
I am getting an error from our ontape level 0 backups. The error message reads
"ISAM error --- no free disk space".
During the backups, there is quite a bit of database activity (inserts, deletes,
updates). I believe that this error is caused by ontape having to preserve
changed log pages in a temporary space while it is running. I think this
defaults to DBSPACETEMP.
Is there any way to make ontape use a Unix filesystem for these temporary files
rather than the temp dbspaces. Or, is the only solution to increase the size of
the temp dbspaces, or possibly create another temp dbspace ( I already have 3
size at 500 MB, 500 MB, and 200 MB).
___________________________________________________________
Jay Aymond
EXE Technologies
jay_aymond@exe.com
Look at the IDS Admin Guide, under Configuration Parameters, under
DBSPACETEMP. It will list the order in which temporary space environment
parameters are scanned to determine space availability.
You can also set DBSPACETEMP at the environment level to override the
contents of the ONCONFIG parameter. You may also want to investigate
DBTEMP.
There are some notes on the http://www.iiug,org website that suggests that
using hard disks for sorts instead of using DBSPACETEMP may actually be
faster. Has anyone researched this any further, in a large environment such
as the one mentioned by Jay?
Take care.
Clifton
Jay Aymond <jay_aymond@exe.com> wrote in message
news:37a33c90.10251009@netnews.worldnet.att.net...
> I am getting an error from our ontape level 0 backups. The error message
reads
> "ISAM error --- no free disk space".
>
> During the backups, there is quite a bit of database activity (inserts,
deletes,
> updates). I believe that this error is caused by ontape having to
preserve
> changed log pages in a temporary space while it is running. I think this
> defaults to DBSPACETEMP.
>
> Is there any way to make ontape use a Unix filesystem for these temporary
files
> rather than the temp dbspaces. Or, is the only solution to increase the
size of
> the temp dbspaces, or possibly create another temp dbspace ( I already
have 3
> size at 500 MB, 500 MB, and 200 MB).
>
>
> ___________________________________________________________
> Jay Aymond
> EXE Technologies
> jay_aymond@exe.com
>
You do not specify what version of IDS you are using so you may have one of
two problems:
Either you do not have enough total tempspace in all tempdbs's or you do not
have large enough tempdbs's. If you have 7.3x then the former is definitely
the problem and you can either add more space to each tempdbs (keep them about
even) or add an additional tempdbs. If you have 7.[12]x you may be running out
of space in only one tempdbs.
In 7.2x the onarchive thread creates a temp table for each dbspace to hold that
space's physical log pre-images of pages modified during the archive round robin
across the tempdbspaces each table in only one tempdbspace. These tables live
until the ENTIRE archive is completed. Since the tables are created round robin
it is possible for the two or three busiest dbspaces' temp tables to be created
in the same tempdbs and therefore for that one to fill up while there is plenty
of space left in the others. For 7.2x then you want, for archive safety, to
have fewer larger tempdbspaces, ideally only one, to reduce this problem. This
is, of course, not ideal for any sorts that use the tempdbspaces and perform
best with at least three tempdbspaces.
In 7.3x Informix fixed this problem. All of the temp tables are fragmented
across all of the temp dbspaces and each table is dropped as soon as the archive
of its dbspace is completed and its contents have been dumped out to tape. For
both these reasons it is better to have more smaller tempdbspaces in 7.3x which
is also good for optimizing sorts that use the tempdbspaces.
It is always a good idea to post version and platform information. At least so
the responses you have to wade through will be shorter.
Art S. Kagel
Jay Aymond wrote:
>
> I am getting an error from our ontape level 0 backups. The error message reads
> "ISAM error --- no free disk space".
>
> During the backups, there is quite a bit of database activity (inserts, deletes,
> updates). I believe that this error is caused by ontape having to preserve
> changed log pages in a temporary space while it is running. I think this
> defaults to DBSPACETEMP.
>
> Is there any way to make ontape use a Unix filesystem for these temporary files
> rather than the temp dbspaces. Or, is the only solution to increase the size of
> the temp dbspaces, or possibly create another temp dbspace ( I already have 3
> size at 500 MB, 500 MB, and 200 MB).
>
> ___________________________________________________________
> Jay Aymond
> EXE Technologies
> jay_aymond@exe.com