RE: error -27001
Posted in 2006
Error 27001, Unable to connect via tcp network connections
This article describes three common causes for listener-thread: err =
-27001: Read error occurred during connection attempt errors.
PROBLEM
The error:
listener-thread: err = -27001: Read error occurred during connection
attempt.
appears in the IBM® Informix® Dynamic Server (IDS) message log file
(ONCONFIG configuration file parameter MSGPATH).
Users are not able to connect to the database server.
CAUSE / SOLUTION
Three common causes and resolutions for the error are:
1. The connectivity files in the /INFORMIXTMP directory are not removed.
The files are in the form of : VP.server_name.0100a
server_name
Database server name as was set in INFORMIXSERVER environment variable and
associated with the tcp connections.
Solution:
Stop the database server, remove the files from the /INFORMIXTMP directory,
and start the database server.
2. The ONCONFIG file settings for the NETTYPE parameter are not correct.
This error is widely seen involving tcp network connections when the VP
class in the NETTYPE setting is set for CPU vp.
Solution:
As a work around Change the vp class setting for the NETTYPE configuration
parameter from CPU to NET.
3. An operating system resource limit was reached. Kernel parameters
settings require changes.
Solution:
Check and possibly increase settings for the following kernel parameters or
parameters equivalent to them depending on Unix platform:
NOFILES
SEMMNU
NFILES
MAXFILES
MAXFILE_LIM
Basim Chafik
Senior Systems Analyst
IBM Certified Advanced Technical Expert (CATE)
1.800.688.4895
basim.chafik@plx.com
plexus (Division of BancTec)
-----Original Message-----
From: hariog@yahoo.com [mailto:hariog@yahoo.com]
Sent: Wednesday, January 11, 2006 11:05 PM
To: informix-list@iiug.org
Subject: error -27001
Hi All,
IDS 10.0.UC3
ELAS3.0, Kernel 2.4.21-4.ELsmp, RAID10
we have got some issues where connections are being dropped out and
online records -27001 error. Database server and application server
(4js) are on the same host. client application uses GDC 1.31.1e and
connecting DB using ODBC (3.82.0000 2.81.TC3 client side). When -27001
occurs, no connection allowed during that time and application
just hangs for about 3-4 mins and comes back to normal after that. We
conatcted application provider and got a response back that they are
testing GDC 1.32.1e which might fix this issue. I am not sure at this
stage whether this read error is at client side or database side,
however, I am suspecting some issues with database side which may or
may not a contributing factor. Here are some snapshots:
onstat -m
13:04:54 listener-thread: err = -27001: oserr = 0: errstr = : Readerror occurred during connection attempt.
onstat -p
IBM Informix Dynamic Server Version 10.00.UC3 -- On-Line -- Up 10
days 05:48:56 -- 1767052 Kbytes
Profile
dskreads pagreads bufreads %cached dskwrits pagwrits bufwrits
%cached
350141411 812650455 72386225639 99.52 5767661 51497061
30441602 90.42
isamtot open start read write rewrite
delete commit rollbk
58499395809 361322842 1054381511 54636023977 41832039 1749311
1049764 1527687 278
gp_read gp_write gp_rewrt gp_del gp_alloc gp_free
gp_curs
31 0 0 0 0 0 52
ovlock ovuserthread ovbuff usercpu syscpu numckpts flushes
0 0 0 286317.00 43055.85 617 1972
bufwaits lokwaits lockreqs deadlks dltouts ckpwaits
compress seqscans
15142198 20 45368091006 0 0 368
1158865 8541139
ixda-RA idx-RA da-RA RA-pgsused lchwaits
42083593 14215347 188961624 241266788 4988764
onstat -g spi
IBM Informix Dynamic Server Version 10.00.UC3 -- On-Line -- Up 10
days 05:50:01 -- 1767052 Kbytes
Spin locks with waits:
Num Waits Num Loops Avg Loop/Wait Name
12 3756897 313074.75 mtcb vproc_sync_lock
232041 89433947 385.42 mtcb sleeping_lock
2 98 49.00 mtcb tcb_queue_lock
17 249360 14668.24 mtcb tcb_queue_lock
69 122322 1772.78 mtcb mutex_list_lock
99 99057 1000.58 mtcb notify_lock
102 22165 217.30 class cl_lock, class = 0
337731 47315091 140.10 vproc vp_lock, id = 1
243903 36604587 150.08 vproc vp_lock, id = 3
1725787 257670671 149.31 vproc vp_lock, id = 4
.....
.....
onstat -g glo
IBM Informix Dynamic Server Version 10.00.UC3 -- On-Line -- Up 10
days 05:51:05 -- 1767052 Kbytes
MT global info:
sessions threads vps lngspins
293 461 31 2671
sched calls thread switches yield 0 yield n yield
forever
total: 2499649188 1174857135 1416527643 4898397
268246790
per sec: 2864 1201 1841 8 53
Virtual processor summary:
class vps usercpu syscpu total
cpu 3 281845.84 3847.27 285693.11
aio 22 3069.21 15118.16 18187.37
lio 1 18.39 95.39 113.78
pio 1 1.78 22.40 24.18
adm 1 10.56 109.81 120.37
soc 2 1327.41 23830.88 25158.29
msc 1 82.00 49.12 131.12
total 31 286355.19 43073.03 329428.22
Individual virtual processors:
vp pid class usercpu syscpu total
1 6103 cpu 51524.72 1693.39 53218.11
2 6104 adm 10.56 109.81 120.37
3 6105 cpu 69208.90 1276.31 70485.21
4 6106 cpu 161112.22 877.57 161989.79
.....
.....
onstat -g ntd
IBM Informix Dynamic Server Version 10.00.UC3 -- On-Line -- Up 10
days 05:53:47 -- 1767052 Kbytes
global network information:
#netscb connects read write q-free q-limits q-exceed
alloc/max
303/ 391 162361 190897185 192280971 88/ 377 379/ 10 0/ 0
382/ 382
Client Type Calls Accepted Rejected Read Write
sqlexec yes 162361 18 174875499 176469418
srvinfx yes 0 0 0 0
onspace yes 0 0 0 0
onlog yes 0 0 0 0
onparam yes 0 0 0 0
oncheck yes 0 0 15435546 15387710
onload yes 0 0 0 0
onunload yes 0 0 0 0
onmonitor yes 0 0 0 0
dr_accept yes 0 0 0 0
cdraccept no