Re: Locked record
Posted in 1998
In article <6s36ah$fbr$1@news.xmission.com>,
"Marek Miloszewski" <marek.miloszewski@zes.szczecin.pl> wrote:
>
> Hi all,
>
> we have a problem with one of our application. Sometimes when somebody is
> inserting new record into one of the tables, other person has a problem with
> entering the application. Here is a message displayed:
>
> Program stopped at "function.4gl", line number 166.
> SQL statement error number -244.
> Could not do a physical-order read to fetch next row.
> SYSTEM error number -107.
> ISAM error: record is locked.>
> The problem is that it does not happened continuously. One day yes, another
> not. Our application producer said this is problem with our Informix
> configuration. But other programs work properly! I don't know were to look
> for error...
>
> Any suggestions?
>
> Marek
>
> -------------------------------------------------------------
> Zaklad Energetyczny Szczecin SA
> ul. Malczewskiego 5/7, 70-952 Szczecin, Poland
> tel: (48 91) 424.00.71 w.5216, fax: (48 91) 22.56.28
> marek.miloszewski@zes.szczecin.pl
> -------------------------------------------------------------
> memorek@polbox.com
> http://www.polbox.com/m/memorek
> -------------------------------------------------------------
>
>
Try to alter the table from page locking into a row-locking.
Alter table xxxxx lock mode (row)
Regards
-----== Posted via Deja News, The Leader in Internet Discussion ==-----
http://www.dejanews.com/rg_mkgrp.xp Create Your Own Free Member Forum