I've
found through trial and error that each alias enumerated by the
onconfig file's DBSERVERALIAS requires its own port in /etc/services.
Is this documented anywhere?
For example:
onconfig:
DBSERVERNAME prod_shm
DBSERVERALIAS ids_gt40_tcp,prod_tcp
/etc/services:
prod_tcp 1536/tcp
gt40_tcp 1537/tcp
sqlhosts:
prod_shm onipcshm gt40 prod_shm
prod_tcp onsoctcp gt40 prod_tcp
ids_gt40_tcp onsoctcp gt40 prod_tcp
oninit -v will fail with error -25572 "Network driver cannot bind name to port"
If I modify the sqlhosts to:
prod_shm onipcshm gt40 prod_shm
prod_tcp onsoctcp gt40 prod_tcp
ids_gt40_tcp onsoctcp gt40 gt40_tcp
The server comes up just fine.
Thanks
Peter
↪ replying to Peter J Diaz de Leon
Peter J
Dia.... wrote:
> I've found through trial and error that each alias enumerated by the
> onconfig file's DBSERVERALIAS requires its own port in /etc/services.
Correct, if they are TCP/IP connections.
> Is this documented anywhere?
Yes, in the fine manual.
> For example:
>
> onconfig:
> DBSERVERNAME prod_shm
> DBSERVERALIAS ids_gt40_tcp,prod_tcp>
> /etc/services:
> prod_tcp 1536/tcp
> gt40_tcp 1537/tcp
>
> sqlhosts:
> prod_shm onipcshm gt40 prod_shm
> prod_tcp onsoctcp gt40 prod_tcp
> ids_gt40_tcp onsoctcp gt40 prod_tcp>
> oninit -v will fail with error -25572 "Network driver cannot bind name toport"
Correct, because prod_tcp has already bound to the port.
> If I modify the sqlhosts to:
> prod_shm onipcshm gt40 prod_shm
> prod_tcp onsoctcp gt40 prod_tcp
> ids_gt40_tcp onsoctcp gt40 gt40_tcp>
> The server comes up just fine.
Well done.
Cheers,
--
Mark.
+----------------------------------------------------------+-----------+
| Mark D. Stock mailto:mdstock@MydasSolutions.com |//////// /|
| Mydas Solutions Ltd http://MydasSolutions.com |///// / //|
| +-----------------------------------+//// / ///|
| |We value your comments, which have |/// / ////|
| |been recorded and automatically |// / /////|
| |emailed back to us for our records.|/ ////////|
+----------------------+-----------------------------------+-----------+