onbar hangs
Posted in 2003
Topics: Backup & Restore, Versions, Editions & End-of-Life
IDS 9.21.UC4
Solaris 2.6
EDS takes our backup using onbar. What we have observed is that,
quite frequently onbar hangs. By hangs it means, onbar processes
keep running indefinitely. Since the backup is taken daily, all
subsequent backups also hang until the earlier on is killed.
I have a script to look for onbar process 15 hours after it
starts, and if it finds one, it sends a mail as follows:-
=========================================
onbar is still running on flx10
root 15709 15703 0 00:50:14 ? 0:00 /bin/sh /opt/informix/bin/onbar -b -L 0
root 15878 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
root 15879 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
root 15873 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
root 15872 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
root 15871 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
root 15874 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
root 15711 15709 0 00:50:14 ? 0:01 /opt/informix/bin/onbar_d -b -L 0
=========================================
The ssyadmin then kills the processes indicated above.
Once they kill the client process, we get this message in online.log
=======================================
15:04:10 Archive on logs02 ABORTED.
15:04:10 Aborted by client.
15:04:10 Archive on logs03 ABORTED.
15:04:10 Aborted by client.
15:04:10 Archive on logs04 ABORTED.
15:04:10 Aborted by client.
15:04:10 Archive on physdbs ABORTED.
15:04:10 Aborted by client.
15:04:11 Archive on fdbs04 ABORTED.
15:04:11 Aborted by client.
15:04:11 Archive on gdbs01 ABORTED.
15:04:11 Aborted by client.
=======================================In other words, the backup is useless.
Earlier on, it use to be once/twice a month. Now it is once/twice a week.
What could be wrong with it. Why does onbar hang for 15 hours without doing
anything.
"rkusenet" <rkusenet@sympatico.ca> wrote in message
news:bgro1s$rbvfo$1@ID-75254.news.uni-berlin.de...
> IDS 9.21.UC4
> Solaris 2.6
>
> EDS takes our backup using onbar. What we have observed is that,
> quite frequently onbar hangs. By hangs it means, onbar processes
> keep running indefinitely. Since the backup is taken daily, all
> subsequent backups also hang until the earlier on is killed.
>
> I have a script to look for onbar process 15 hours after it
> starts, and if it finds one, it sends a mail as follows:-
>
> =========================================
> onbar is still running on flx10
> root 15709 15703 0 00:50:14 ? 0:00 /bin/sh /opt/informix/bin/onbar -b -L 0
> root 15878 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15879 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15873 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15872 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15871 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15874 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15711 15709 0 00:50:14 ? 0:01 /opt/informix/bin/onbar_d -b -L 0
> =========================================
>
> The ssyadmin then kills the processes indicated above.
>
> Once they kill the client process, we get this message in online.log
> =======================================
> 15:04:10 Archive on logs02 ABORTED.
> 15:04:10 Aborted by client.
> 15:04:10 Archive on logs03 ABORTED.
> 15:04:10 Aborted by client.
> 15:04:10 Archive on logs04 ABORTED.
> 15:04:10 Aborted by client.
> 15:04:10 Archive on physdbs ABORTED.
> 15:04:10 Aborted by client.
> 15:04:11 Archive on fdbs04 ABORTED.
> 15:04:11 Aborted by client.
> 15:04:11 Archive on gdbs01 ABORTED.
> 15:04:11 Aborted by client.
> =======================================> In other words, the backup is useless.
>
> Earlier on, it use to be once/twice a month. Now it is once/twice a week.
> What could be wrong with it. Why does onbar hang for 15 hours without doing
> anything.
Which manual describes onbar commands for 9.21?
It seems it has something to do with parallelism.
current request exceeds parallelism.
solaris log file shows this error:-
> XBSA-1.0.1 6.0.Build.153 15872 Wed Aug 6 00:52:17 2003
> _nwbsa_is_retryable_error: received a retryable network error
> (Severity 0 Number -13): current request exceeds parallelism
> XBSA-1.0.1 6.0.Build.153 15873 Wed Aug 6 00:52:17 2003
> _nwbsa_is_retryable_error: received a retryable network error
> (Severity 0 Number -13): current request exceeds parallelism
> XBSA-1.0.1 6.0.Build.153 15871 Wed Aug 6 00:52:17 2003
> _nwbsa_is_retryable_error: received a retryable network error
> (Severity 0 Number -13): current request exceeds parallelism
> XBSA-1.0.1 6.0.Build.153 15874 Wed Aug 6 00:52:19 2003
> _nwbsa_is_retryable_error: received a retryable network error
> (Severity 0 Number -13): current request exceeds parallelism
I would like to see whether there are options in onbar to turn off
parallelism.
Are you running parallel backups and if yes do you have enough
tape heads in the storage device? What else is using the storage
device at the time this is running?
rkusenet wrote:
>
> IDS 9.21.UC4
> Solaris 2.6
>
> EDS takes our backup using onbar. What we have observed is that,
> quite frequently onbar hangs. By hangs it means, onbar processes
> keep running indefinitely. Since the backup is taken daily, all
> subsequent backups also hang until the earlier on is killed.
>
> I have a script to look for onbar process 15 hours after it
> starts, and if it finds one, it sends a mail as follows:-
>
> =========================================
> onbar is still running on flx10
> root 15709 15703 0 00:50:14 ? 0:00 /bin/sh /opt/informix/bin/onbar -b -L 0
> root 15878 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15879 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15873 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15872 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15871 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15874 15711 0 00:51:14 ? 0:00 /opt/informix/bin/onbar_d -b -L 0
> root 15711 15709 0 00:50:14 ? 0:01 /opt/informix/bin/onbar_d -b -L 0
> =========================================
>
> The ssyadmin then kills the processes indicated above.
>
> Once they kill the client process, we get this message in online.log
> =======================================
> 15:04:10 Archive on logs02 ABORTED.
> 15:04:10 Aborted by client.
> 15:04:10 Archive on logs03 ABORTED.
> 15:04:10 Aborted by client.
> 15:04:10 Archive on logs04 ABORTED.
> 15:04:10 Aborted by client.
> 15:04:10 Archive on physdbs ABORTED.
> 15:04:10 Aborted by client.
> 15:04:11 Archive on fdbs04 ABORTED.
> 15:04:11 Aborted by client.
> 15:04:11 Archive on gdbs01 ABORTED.
> 15:04:11 Aborted by client.
> =======================================> In other words, the backup is useless.
>
> Earlier on, it use to be once/twice a month. Now it is once/twice a week.
> What could be wrong with it. Why does onbar hang for 15 hours without doing
> anything.
--
Paul Watson #
Oninit Ltd # Growing old is mandatory
Tel: +44 1436 672201 # Growing up is optional
Fax: +44 1436 678693 #
Mob: +44 7818 003457 #
www.oninit.com #