Oninit in LINUX
Posted in 2000
Topics: Stored Procedures & SPL, Platform-Specific Issues
Hi Why display "fd dup" when up database with IDS-7.3X. This message is a warning or error Thanks for help Ruben Sent via Deja.com http://www.deja.com/ Before you buy.
This is kernel's warning. Simple ignore it - IDS will work well. ( IDS-7.3X does a lot of 'dup' system calls ( more then upper limit of kernel ) even if you'll try to enlarge kernel's open files limit, you'll do not be able to decide this problem. I think this is error on IDS. ) This problem is solved on IDS-2000. Ruben Dutan <rdutan@my-deja.com> ''''' ' ''''''''':8spv8m$f67$1@nnrp1.deja.com... > Hi > Why display "fd dup" when up database with IDS-7.3X. This message > is a warning or error > > Thanks for help > Ruben > > > Sent via Deja.com http://www.deja.com/ > Before you buy.
Thank you Sergey for help In article <8ssco3$qia2@www.informix.com>, "Sergey E. Volkov" <sve@raiden.bancorp.ru> wrote: > This is kernel's warning. Simple ignore it - IDS will work well. > > ( IDS-7.3X does a lot of 'dup' system calls ( more then upper limit of > kernel ) even if you'll try to enlarge kernel's > open files limit, you'll do not be able to decide this problem. I think > this is error on IDS. ) > > This problem is solved on IDS-2000. > > Ruben Dutan <rdutan@my-deja.com> ''''' ' > ''''''''':8spv8m$f67$1@nnrp1.deja.com... > > Hi > > Why display "fd dup" when up database with IDS-7.3X. This message > > is a warning or error > > > > Thanks for help > > Ruben > > > > > > Sent via Deja.com http://www.deja.com/ > > Before you buy. > > Sent via Deja.com http://www.deja.com/ Before you buy.
In article <8ssco3$qia2@www.informix.com>, Sergey E. Volkov wrote: >This is kernel's warning. Simple ignore it - IDS will work well. > >( IDS-7.3X does a lot of 'dup' system calls ( more then upper limit of >kernel ) even if you'll try to enlarge kernel's >open files limit, you'll do not be able to decide this problem. I think >this is error on IDS. ) > I don't think this is an error so much as the mechanism IDS uses to determine the maximum fd number available to it's process. TTFN -- Roger Think of the mess on the carpet. Sensible people do all their demon-summoning in the garage, which you can just hose down afterwards. -- damerell@chiark.greenend.org.uk
This ina known problem in the 7.3x version of Informix that was teleased for Linux. The problem is that Informix wants about 3000 fd's, and most versions of Linux are limited to 1024. How to fix this depends on the version of the Kernel adn which release of Linux is being used. Real early versions of Linux require an edit & compile, other versions require using the /proc interface, and the newest ones use a configuration file. Keep in mind that there are two places where the # of fd's is limited. One is at the OS level, the other is at the users level (but root's user level limit is the same as the OS). Sorry if the fixes are vague, but I don't have my notes handy at the moment. I have run 7.3x under RH 6.0-6.2 and Mandrake 7.1 . RH 6.2 & Mandrake 7.1 are the easiest to work with. S.W. Roger Gammans wrote: > > In article <8ssco3$qia2@www.informix.com>, Sergey E. Volkov wrote: > >This is kernel's warning. Simple ignore it - IDS will work well. > > > >( IDS-7.3X does a lot of 'dup' system calls ( more then upper limit of > >kernel ) even if you'll try to enlarge kernel's > >open files limit, you'll do not be able to decide this problem. I think > >this is error on IDS. ) > > > I don't think this is an error so much as the mechanism IDS uses > to determine the maximum fd number available to it's process. > > TTFN > -- > Roger > Think of the mess on the carpet. Sensible people do all their > demon-summoning in the garage, which you can just hose down afterwards. > -- damerell@chiark.greenend.org.uk >
Steven Wilcoxon <swilcoxon@uswest.net> writes: > This ina known problem in the 7.3x version of Informix that was teleased > for Linux. The problem is that Informix wants about 3000 fd's, and most > versions of Linux are limited to 1024. How to fix this depends on the > version of the Kernel adn which release of Linux is being used. Real > early versions of Linux require an edit & compile, other versions > require using the /proc interface, and the newest ones use a > configuration file. > > Keep in mind that there are two places where the # of fd's is limited. > One is at the OS level, the other is at the users level (but root's user > level limit is the same as the OS). > > Sorry if the fixes are vague, but I don't have my notes handy at the > moment. I have run 7.3x under RH 6.0-6.2 and Mandrake 7.1 . RH 6.2 & > Mandrake 7.1 are the easiest to work with. FD and tasks? Take a look at http://www.volano.com/linuxnotes.html Thomas