Re: Lot of "listener-thread: err = -25580: oserr = 0:..."
Posted in 2008
Topics: Platform-Specific Issues, Versions, Editions & End-of-Life
Cesar Inacio Martins wrote:
You day "the solution doesn't work here" but did netstat -s report
dropped connection attempts? What does
ndd -get /dev/tcp tcp_conn_request_max
show is the current setting for tcp_conn_request_max? If it's now 256
did you try to increase that to 512?
How many concurrent user connections do you typically have at the time
these messages appear?
Art S. Kagel
Oninit
> Hi,
>
> IDS 7.31FD2
> HP-UX b11.00
>
> A few days ago start appear on the message log the error
> "listener-thread: err = -25580: oserr = 0: errstr = : System error
> occurred in network function.".
>
> After research the only thing I found is this article :
> http://www-1.ibm.com/support/docview.wss?uid=swg21207733
>
> But , the solution don't work here...
> 99% of users connect through IPCSTR .
>
> After restart the database when the users back to connect , the error
> start again...
>
> any tips ?
>
> #cat online.log |grep listene
> 09:13:29 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 09:30:59 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 09:48:29 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 10:06:00 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 10:23:30 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 10:41:00 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 10:58:30 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 11:16:00 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 11:19:09 listener-thread: err = -27001: oserr = 0: errstr = : Read> error occurred during connection attempt.
> 11:33:30 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 11:51:00 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 12:08:30 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 12:26:00 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 12:43:30 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 13:01:00 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 13:18:30 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 13:36:00 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 13:53:30 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 14:11:00 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 14:28:30 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 14:46:01 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 15:03:31 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 15:21:01 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
> 15:38:31 listener-thread: err = -25580: oserr = 0: errstr = : System> error occurred in network function.
>
> #onstat -c |egrep "NET|CPU"
> NETTYPE soctcp,1,100,NET # Configure poll thread(s) for nettype
> NETTYPE ipcstr,4,150,NET # Configure poll thread(s) for nettype
> NUMCPUVPS 4 # Number of user (cpu) vps
> SINGLE_CPU_VP 0 # If non-zero, limit number of cpu vps> to one
>
>
> #onstat -g ntu |grep -v sqlexec
>
> Informix Dynamic Server Version 7.31.FD2 -- On-Line -- Up 1 days
> 14:34:07 -- 3061584 Kbytes
>
> global network information:
> #netscb connects read write q-free q-limits q-exceed
> alloc/max
> 429/ 523 5135 36327755 36935738 63/ 275 275/ 10 1135/ 0
> 876/ 883
>
> Individual thread network information (basic):
> netscb type thread name sid fd poll reads writes
> q-nrm q-pvt q-exp
> c00000008b0677d8 ipcstr ipcstr_exp 10 6 9 0
> 0 0/ 0 0/ 0 0/ 0
> c00000008b018fa0 soctcp soctcplst 13 7 5 0
> 0 0/ 0 0/ 0 0/ 0
> c00000008b016a98 soctcp soctcplst 12 5 5 49
> 0 0/ 0 0/ 0 0/ 0
> c00000008b013408 ipcstr ipcstr_exp 8 3 7 0
> 0 0/ 0 0/ 0 0/ 0
> c00000008b012530 ipcstr ipcstrlst 10 4 8 96
> 0 0/ 0 0/ 0 0/ 0
> c00000008b011b38 ipcstr ipcstrlst 8 2 6 4988
> 0 0/ 0 0/ 0 0/ 0
> c00000008afd5b60 soctcp soctcplst 7 1 5 2
> 0 0/ 0 0/ 0 0/ 0
> c00000008afaf870 ipcstr ipcstrpoll 6 0 9 9167486
> 0 0/ 0 0/ 0 0/ 0
> c00000008af89018 ipcstr ipcstrpoll 5 0 8 5713302
> 0 0/ 0 0/ 0 0/ 0
> c00000008af7c880 ipcstr ipcstrpoll 4 0 7 9643565
> 0 0/ 0 0/ 0 0/ 0
> c00000008af5f018 ipcstr ipcstrpoll 3 0 6 11803372
> 0 0/ 0 0/ 0 0/ 0
> c00000008af3a028 soctcp soctcppoll 2 0 5 53
> 0 0/ 0 0/ 0 0/ 0
>
>
> ------------------------------------------------------------------------
> Abra sua conta no Yahoo! Mail
> <http://br.rd.yahoo.com/mail/taglines/mail/*http://br.mail.yahoo.com/>,
> o único sem limite de espaço para armazenamento!
> ------------------------------------------------------------------------
>
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
>
Art S. Kagel (Oninit) wrote: > Cesar Inacio Martins wrote: > > You day "the solution doesn't work here" but did netstat -s report > dropped connection attempts? What does > > ndd -get /dev/tcp tcp_conn_request_max > > show is the current setting for tcp_conn_request_max? If it's now 256 > did you try to increase that to 512? > > How many concurrent user connections do you typically have at the time > these messages appear? > > Art S. Kagel > Oninit > >> Hi, >> >> IDS 7.31FD2 >> HP-UX b11.00 >> <snip> I would suggest getting off HP-UX 11.00, and going to 11.11 (HP-UX 11iV1, or whatever is the latest PA-RISC version). Or at least making sure you have the last QPK and HWE bundles. From the HP Site : "HP offered the final Quality Pack (QPK) and Hardware Enablement (HWE) bundles for HP-UX 11.0 with the March 2004 release. This is in alignment with the obsolescence of HP-UX 11.0 on March 31, 2004."