onstat: Shared memory: permission denied???
Posted in 2000
Topics: Security, Permissions & Auditing, Platform-Specific Issues
Greetings,
I'm receiving the following error message when I run onstat - as any user
other than root and informix:
#onstat -
onstat: Shared memory: permission denied
I've searched through Answers Online and found nothing.
I am running Informix Dynamic Server.2000 on a RedHat Linux 6.2 system.
Any help is appreciated,
Marc Thompson
--
---------------------------------------
Marc Thompson
BOPS, Inc.
Austin, TX
Marc,
You might try adding that 'other' user to the informix group.
Here's what 'ipcs' outputs on my system:
IPC status from <running system> as of Tue Jun 6 10:38:3
Message Queue facility not in system.
T ID KEY MODE OWNER GROUP
Shared Memory:
m 800 0x52574801 --rw-rw---- root informix
m 801 0x52574802 --rw-rw---- root informix
m 802 0x52574803 --rw-rw---- root informix
So if a user isn't root, informix or in the informix group they won't
have permissions to read the shared memory segments..
The groups on my solaris 2.6 are in /etc/group.
Dave
In article <960306588.533683@curry>,
"Marc Thompson" <MarcT@bops.com> wrote:
> Greetings,
>
> I'm receiving the following error message when I run onstat - as any
user
> other than root and informix:
>
> #onstat -
> onstat: Shared memory: permission denied
>
> I've searched through Answers Online and found nothing.
>
> I am running Informix Dynamic Server.2000 on a RedHat Linux 6.2
system.
>
> Any help is appreciated,
> Marc Thompson
>
> --
> ---------------------------------------
> Marc Thompson
> BOPS, Inc.
> Austin, TX
>
>
Sent via Deja.com http://www.deja.com/
Before you buy.
Thanks to everyone who responded. The solution had eluded
me until I read the responses to my post.
The problem was simple: I had restored from tape after a crash
and the restoration program (Arkeia) failed to set the suid bit on
*lots* of files. Onstat has to run suid root. Easy enough to fix.
Thanks again,
Marc Thompson
--
---------------------------------------
Marc Thompson
BOPS, Inc.
Austin, TX
Marc Thompson <MarcT@bops.com> wrote in message
news:960306588.533683@curry...
> Greetings,
>
> I'm receiving the following error message when I run onstat - as any user
> other than root and informix:
>
> #onstat -
> onstat: Shared memory: permission denied
>
> I've searched through Answers Online and found nothing.
>
> I am running Informix Dynamic Server.2000 on a RedHat Linux 6.2 system.
>
> Any help is appreciated,
> Marc Thompson
>
> --
> ---------------------------------------
> Marc Thompson
> BOPS, Inc.
> Austin, TX
>
>