RE: WARNING! Physical Log size 50000 is too small ?? Why ? And ho
Posted in 2003
Topics: Storage & Space Management, Logging & Checkpoints, Platform-Specific Issues
The physical log is recommended to allow for 20 pages per user to be changed
between checkpoints. As the checkpoint occurs when the phys log gets to 75%
full it really means that the sizing assumption is 15 changed pages per
user. If you aren't making that many changes then you don't need to make
the increase, but the error indicates that you are using more than that "on
average". If the error occurs frequently then increase the size. I would
consider the checkpoint frequency as well in making the decision.
Hope this helps
Malcolm
-----Original Message-----
From: jerrytu@mail2000.com.tw [mailto:jerrytu@mail2000.com.tw]
Sent: 02 July 2003 08:28
To: informix-list@iiug.org
Subject: WARNING! Physical Log size 50000 is too small ?? Why ? And how to
fix it ?
Dear Here,
Today,I found following warning in online.log .
My database OS is AIX and DB is Informix Database server 7.3.
09:05:45 WARNING! Physical Log size 50000 is too small. Physical Log overflows may occur during peak activity.
Recommended minimum Physical Log size is 20 times maximum
concurrent user threads.
I had config Physical and Logical :
# Physical Log Configuration
PHYSDBS rootdbs # Location (dbspace) of physical log
PHYSFILE 50000 # Physical log file size (Kbytes)
# Logical Log Configuration
LOGFILES 120 # Number of logical log files
LOGSIZE 2000 # Logical log size (Kbytes)
Actually , My dbspace in used is 27% and 73% is avaiabled .
and concurrent user between 500-600 and each user session size is 7k .
So , Physical Log size should be enough .
Why this warning happen ? and How to fix it ?
PLS Help me !! Thanks.
Regards
Jerry
**************************************************************************
The information transmitted herewith is sensitive information intended only
for use by the individual or entity to which it is addressed. If the reader
of this message is not the intended recipient, you are hereby notified that
any review, retransmission, dissemination, distribution, copying or other
use of, or taking of any action in reliance upon this information is
strictly prohibited. If you have received this communication in error,
please contact the sender and delete the material from your computer.
sending to informix-list
"Weallans, Malcolm" <Malcolm.Weallans@capitalone.com> wrote in message
news:bdub66$m6t$1@terabinaries.xmission.com...
>
> The physical log is recommended to allow for 20 pages per user to be
changed
> between checkpoints. As the checkpoint occurs when the phys log gets to
75%
> full it really means that the sizing assumption is 15 changed pages per
> user. If you aren't making that many changes then you don't need to make
> the increase, but the error indicates that you are using more than that
"on
> average". If the error occurs frequently then increase the size. I would
> consider the checkpoint frequency as well in making the decision.
> Hope this helps
>
> Malcolm
>
Increase the size anyway. Why can you not increase this to
say 75M or even 100Mb and see if the warning goes away?
Informix is clearly warning you for a reason and an extra
25/50Mb is nothing
> -----Original Message-----
> From: jerrytu@mail2000.com.tw [mailto:jerrytu@mail2000.com.tw]
> Sent: 02 July 2003 08:28
> To: informix-list@iiug.org
> Subject: WARNING! Physical Log size 50000 is too small ?? Why ? And how to
> fix it ?
>
> Dear Here,
>
> Today,I found following warning in online.log .
> My database OS is AIX and DB is Informix Database server 7.3.
>
> 09:05:45 WARNING! Physical Log size 50000 is too small.> Physical Log overflows may occur during peak activity.
> Recommended minimum Physical Log size is 20 times maximum
> concurrent user threads.
>
> I had config Physical and Logical :
>
> # Physical Log Configuration
> PHYSDBS rootdbs # Location (dbspace) of physical log
> PHYSFILE 50000 # Physical log file size (Kbytes)>
> # Logical Log Configuration
> LOGFILES 120 # Number of logical log files
> LOGSIZE 2000 # Logical log size (Kbytes)>
> Actually , My dbspace in used is 27% and 73% is avaiabled .
> and concurrent user between 500-600 and each user session size is 7k .
>
> So , Physical Log size should be enough .
> Why this warning happen ? and How to fix it ?
> PLS Help me !! Thanks.
>
> Regards
> Jerry
>
> **************************************************************************
> The information transmitted herewith is sensitive information intended
only
> for use by the individual or entity to which it is addressed. If the
reader
> of this message is not the intended recipient, you are hereby notified
that
> any review, retransmission, dissemination, distribution, copying or other
> use of, or taking of any action in reliance upon this information is
> strictly prohibited. If you have received this communication in error,
> please contact the sender and delete the material from your computer.
> sending to informix-list