Re: Stored procedure executing system calls
Posted in 1998
What system command are you executing? Is it producing any output? It sounds to me like you are having a permission problem on whatever output file the system command is executing and since it cannot overwrite the file, it is failing. That would also explain why it works all the time as root. If this is the problem you have several options. 1.) Run as root 2.) Insert a chmod of any files created into the process 3.) Create unique file names each time --- On Wed, 24 Jun 1998 12:03:06 +0100 Danny Williams <dummy@email.address> wrote: Hi there! I have a problem with a stored procedure that is executing a system call. I am on Informix Online 7.22.uc1 on AIX 4.2.1. The problem is that after I have brought the instance online, the stored procedure will execute a few times before failing with a 668 error. I can then take the instance offline and bring it back online again and it will then work. To make it work all the time, all I have to do is start online as root instead of informix. Therefore, I guess it is a resource problem but I can't track what resource is constrained. I don't believe it to be the number of processes a user can execute as I have raised it to 200 and this still did not fix the fault. Any ideas anyone? Danny ---------------End of Original Message----------------- -------------------------------------------------------- Name: Bill Weaver E-mail: Bill Weaver <billw@fscorp.com> Date: 06/24/98 Time: 09:48:31 This message was sent by Z-Mail Pro - from NetManage NetManage - delivers Standards Based IntraNet Solutions --------------------------------------------------------