Error occurs when oninit: DBSERVERNAME 'sharp' not in sqlhosts file.
Posted in 2006
Topics: Security, Permissions & Auditing, Networking & sqlhosts Configuration
The machine is restarted but Informix does not come up automatically. I
use oninit without options to bring Informix database server online. I
get an error message then as following, how can I do with it? Can I
edit the sqlhosts file manually and add an entry to correct the error?
Thank you.
$ su root -c './ids_hp/bin/oninit'
Password:oninit: DBSERVERNAME 'sharp' not in sqlhosts file or sqlhosts file
contents
are damaged.
$
None wrote:
> The machine is restarted but Informix does not come up automatically. I
> use oninit without options to bring Informix database server online. I
> get an error message then as following, how can I do with it? Can I
> edit the sqlhosts file manually and add an entry to correct the error?
> Thank you.
>
> $ su root -c './ids_hp/bin/oninit'
> Password:> oninit: DBSERVERNAME 'sharp' not in sqlhosts file or sqlhosts file
> contents
> are damaged.
> $
The content of the file ./ids_hp/etc/sqlhosts is:
#**************************************************************************
#
# INFORMIX SOFTWARE, INC.
#
# PROPRIETARY DATA
#
# THIS DOCUMENT CONTAINS TRADE SECRET DATA WHICH IS THE PROPERTY OF
# INFORMIX SOFTWARE, INC. THIS DOCUMENT IS SUBMITTED TO RECIPIENT IN
# CONFIDENCE. INFORMATION CONTAINED HEREIN MAY NOT BE USED, COPIED OR
# DISCLOSED IN WHOLE OR IN PART EXCEPT AS PERMITTED BY WRITTEN
AGREEMENT
# SIGNED BY AN OFFICER OF INFORMIX SOFTWARE, INC.
#
# THIS MATERIAL IS ALSO COPYRIGHTED AS AN UNPUBLISHED WORK UNDER
# SECTIONS 104 AND 408 OF TITLE 17 OF THE UNITED STATES CODE.
# UNAUTHORIZED USE, COPYING OR OTHER REPRODUCTION IS PROHIBITED BY LAW.
#
#
# Title: sqlhosts.demo
# Sccsid: @(#)sqlhosts.demo 9.2 7/15/93 15:20:45
# Description:
# Default sqlhosts file for running demos.
#
#**************************************************************************
#demo_on onipcshm on_hostname on_servername#demo_se seipcpip se_hostname sqlexec
thbs onsoctcp sharp inf_thbs
#cssdev onsoctcp sharp cssdev
#csspat onsoctcp sharp inf_csspatcitpatsoc onsoctcp sharp citpatsoc s=0
citpat onsoctcp sharp citpat s=0
#citpatshm onipcshm sharp citpatshm
spvjt_sharp onsoctcp sharp spvjt_sharp
spvjt_sharpshm onipcshm sharp spvjt_sharpshm
spvjt_sharpsoc onsoctcp sharp spvjt_sharpsoc
jt_enable onsoctcp sharp jt_enable
jt_enableshm onipcshm sharp jt_enableshm
jt_enablesoc onsoctcp sharp jt_enablesoc
css_enable onsoctcp sharp css_enable
css_enableshm onipcshm sharp css_enableshm
css_enablesoc onsoctcp sharp css_enablesoc
Seems that your env is incorrect when trying to start the database.
su root -c 'env > /tmp/tessie'
what does /tmp/tessie contain??
hopefully
ONCONFIG, INFORMIXSERVER, INFORMIXDIR
please check it. saw your sqlhost file, based on that i assume that
INFORMIXSERVER and ONCONFIG are not set properly.
Superboer.
BTW i would start the database as user informix, not as root.
there were some security problems in the past....
None schreef:
> The machine is restarted but Informix does not come up automatically. I
> use oninit without options to bring Informix database server online. I
> get an error message then as following, how can I do with it? Can I
> edit the sqlhosts file manually and add an entry to correct the error?
> Thank you.
>
> $ su root -c './ids_hp/bin/oninit'
> Password:> oninit: DBSERVERNAME 'sharp' not in sqlhosts file or sqlhosts file
> contents
> are damaged.
> $