DEC Alpha, OL 7.1 bug
Posted in 1995
We have discovered a problem with using OnLine 7.1 on the DEC Alpha platform running OSF/1 v3.0. When running an update of the form: UPDATE table SET attribute = value WHERE attribute = whatever the engine will update only 129 rows, regardless of how many there are that meet the criterion. Worse, it reports a success status. (We have some paranoid code that checked the number of rows, and found that the number to update did not match the number updated.) This only happens when there is an index on 'attribute', and there is a WHERE clause used. Informix support could not reproduce the error on a Sun machine, maybe it only happens on DEC Alphas. We are (still) waiting on a patch, or something, this "challenge" has been assigned problem number 36725. In the meantime, we are writing more cautious code to check things like this, and explicitly commiting each update *before* 129 rows. Remember, just because you are paranoid doesn't mean they are *not* out to get you... __________________________________________________________________ | Clem Akins Standard Disclaimers Apply | |Reynolds Metals Co, Alloys Plant "Climb High, Cave Deep!" | | Muscle Shoals, Alabama USA cwakins@leia.alloys.rmc.com | |________________________________________________________________|