IDS throws an error after database import
Posted in 2009
Topics: Server Administration, Migration, Import/Export & Data Conversion
Hi,
We are using IDS 11.5 in RHEL 5.3 environment.
We did the database export/import using the following commands!
1. database export using the dbexport command
2. dropped the database using the "dbaccess" command
3. Imported the database using dbimport command.
Import reports a successful completion.
But we are getting an error "set isolation to committed read failed" and could
not connect to the databse
Any help appreciated!!!!!
Thanks,
Lakshmi
Lakshmi,
The error you are getting indicates you don't have logging turned on. Without
specifying the appropriate command line parameter for dbimport, the newly
imported database will default to no logging.
Rob Schmitz
Embarq Data Management
rob.b.schmitz@embarq.com
www.embarq.com
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of LAKSHMI
DEVI PALANISSAMY
Sent: Thursday, March 12, 2009 10:06 AM
To: ids@iiug.org
Subject: IDS throws an error after database import [15110]
Hi,
We are using IDS 11.5 in RHEL 5.3 environment.
We did the database export/import using the following commands!
1. database export using the dbexport command
2. dropped the database using the "dbaccess" command
3. Imported the database using dbimport command.
Import reports a successful completion.
But we are getting an error "set isolation to committed read failed" and could
not connect to the databse
Any help appreciated!!!!!
Thanks,
Lakshmi
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
When you ran the dbimport you did not specify "-l" or "-l buffered" so the
new database was created without logging and so without transaction
support. No transactions, no committed read isolation. Either drop and
dbimport again with -l or run ondblog then ontape -s to change the
database's logging mode.
Art
On Thu, Mar 12, 2009 at 11:05 AM, LAKSHMI DEVI PALANISSAMY <
lakshmidevip@hcl.in> wrote:
> Hi,
>
> We are using IDS 11.5 in RHEL 5.3 environment.
>
> We did the database export/import using the following commands!
> 1. database export using the dbexport command
> 2. dropped the database using the "dbaccess" command
> 3. Imported the database using dbimport command.
>
> Import reports a successful completion.
> But we are getting an error "set isolation to committed read failed" and
> could
> not connect to the databse
>
> Any help appreciated!!!!!
>
> Thanks,
> Lakshmi
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
--0016364ef1cc11338b0464eecd73
i been doing something similar lately
After the dbimport i had to change it to logging with
ontape -B DB_NAME -s -L 0
After the level 0 backup the loogin will be changed to buffered
I used the -l along with dbimport. It is working fine!!