Re: Error in Enterprise Replication
Posted in 2007
Hi all,
Actually, I am using the application which is apparently using dbaccess in the background. For some reason, I cannot ask my vendor to change the application therefore, I am using the other way around i.e. adding more logs or freeing previous logs which are used and backed up. In following case, I am trying to recreate all logical logs with comparatively bigger size than current. When I try to remove any used and backed-up log it gives me error:
"Enterprise Replication is not yet done snooping this log. Drop failed.".
I cannot understand why this error was encountered, when IDS is up(restarted) and replication is not running. Kindly advice how can I remove logical log number 1 to 19.
Test >onstat -l
IBM Informix Dynamic Server Version 10.00.UC5 -- On-Line -- Up 00:00:27 -- 46240 Kbytes
Physical Logging Buffer bufused bufsize numpages numwrits pages/io
P-2 0 8 7 1 7.00
phybegin physize phypos phyused %used
8:6931 2500 15 8 0.32
Logical Logging
Buffer bufused bufsize numrecs numpages numwrits recs/pages pages/io
L-3 0 8 31 5 5 6.2 1.0
Subsystem numrecs Log Space used
OLDRSAM 31 1952
address number flags uniqid begin size used %used
502344b0 1 U-B---- 534 1:763 500 500 100.00
502344f8 2 U-B---- 535 1:1263 500 500 100.00
50234540 3 U-B---- 536 1:1763 500 500 100.00
50234588 4 U-B---- 537 1:2263 500 500 100.00
502345d0 7 U-B---- 538 8:923 500 500 100.00
50234618 5 U-B---- 539 1:2763 500 500 100.00
50234660 6 U-B---- 540 1:3263 500 500 100.00
502346a8 8 U-B---- 541 4:71993 500 500 100.00
502346f0 11 U-B---- 542 4:72993 500 500 100.00
50234738 9 U-B---- 543 4:72493 500 500 100.00
50234780 10 U-B---- 544 8:1431 500 500 100.00
502347c8 12 U-B---- 545 8:1931 5000 5000 100.00
50234810 13 U-B---- 546 8:11931 5000 5000 100.00
50234858 14 U-B---- 547 8:16931 5000 5000 100.00
502348a0 15 U---C-L 548 8:21931 5000 2117 42.34
502348e8 16 U-B---- 530 8:26931 5000 5000 100.00
50234930 17 U-B---- 531 6:3 5000 5000 100.00
50234978 18 U-B---- 532 6:5003 5000 5000 100.00
502349c0 19 U-B---- 533 6:10003 5000 5000 100.00
19 active, 19 total
Test >onparams -d -l 19 -y
Enterprise Replication is not yet done snooping this log.
Drop failed.
ISAM error: Unexpected internal error
Test >oninit oninit: Fatal error in shared memory creation
Test >onstat -
IBM Informix Dynamic Server Version 10.00.UC5 -- On-Line -- Up 00:04:05 -- 46240 Kbytes
Test >cdr stop command failed -- Enterprise Replication not active (62)
Test >
Regards,
Navaid Arif
----- Original Message -----
From: Navaid Arif
To: admin-tools@iiug.org ; informix-list@iiug.org ; classics@iiug.org ; ids@iiug.org
Sent: Wednesday, May 16, 2007 6:12 PM
Subject: Re: Error in Enterprise Replication
Hi All,
I have increased the number of logical logs by adding 9 more logical logs of 20MB each. Now I have 20 logical logs. But the problem is that after performing some table load activity all logs have become 100% used. At this stage, no application is running even I have restarted the IDS but previous logs are still showing 100% utilization of logical logs and no more space is available showing error "LONG TRANSACTION DETECTED".
I will really appreciate if someone will help me in freeing this logical logs space.
Test >onstat -l
IBM Informix Dynamic Server Version 10.00.UC5 -- Quiescent -- Up 00:55:25 -- 46240 Kbytes
Physical Logging Buffer bufused bufsize numpages numwrits pages/io
P-1 6 8 8337 1196 6.97
phybegin physize phypos phyused %used
8:6931 5000 4627 6 0.12
Logical Logging
Buffer bufused bufsize numrecs numpages numwrits recs/pages pages/io
L-1 0 8 1326284 29680 4626 44.7 6.4
Subsystem numrecs Log Space used
OLDRSAM 1326282 116667676
SBLOB 1 44
CDR 1 40
address number flags uniqid begin size used %used
502344b0 1 U-B---- 534 1:763 500 500 100.00
502344f8 2 U-B---- 535 1:1263 500 500 100.00
50234540 3 U-B---- 536 1:1763 500 500 100.00
50234588 4 U-B---- 537 1:2263 500 500 100.00
502345d0 7 U-B---- 538 8:923 500 500 100.00
50234618 5 U-B---- 539 1:2763 500 500 100.00
50234660 6 U-B---- 540 1:3263 500 500 100.00
502346a8 8 U-B---- 541 4:71993 500 500 100.00
502346f0 11 U-B---- 542 4:72993 500 500 100.00
50234738 9 U-B---- 543 4:72493 500 500 100.00
50234780 10 U-B---- 544 8:1431 500 500 100.00
502347c8 12 U-B---- 545 8:1931 5000 5000 100.00
50234810 13 U-B---- 546 8:11931 5000 5000 100.00
50234858 14 U-B---- 547 8:16931 5000 5000 100.00
502348a0 15 U---C-L 548 8:21931 5000 317 6.34
502348e8 16 U-B---- 530 8:26931 5000 5000 100.00
50234930 17 U-B---- 531 6:3 5000 5000 100.00
50234978 18 U-B---- 532 6:5003 5000 5000 100.00
502349c0 19 U-B---- 533 6:10003 5000 5000 100.00
604bbfb0 20 A------ 0 6:15003 5000 0 0.00
20 active, 20 total
Test >
Regards,
Navaid Arif
----- Original Message -----
From: Navaid Arif
To: admin-tools@iiug.org ; informix-list@iiug.org ; peoplemix@iiug.org ; classics@iiug.org ; ids@iiug.org
Sent: Wednesday, May 02, 2007 11:36 AM
Subject: Error in Enterprise Replication
Hi All,
I am using IDS 10 UC5 and during testing of Enterprise Repl