Re: A teensy-weensy little oversight in the QA suite?
Posted in 2010
Topics: Backup & Restore, Performance & Tuning, Installation, Setup & Upgrades, Storage & Space Management, Stored Procedures & SPL, Security, Permissions & Auditing, Data Types & Schema Design, Triggers, Constraints & Referential Integrity, Logging & Checkpoints, Migration, Import/Export & Data Conversion, Platform-Specific Issues
On 29 Jan, 14:01, Fernando Nunes <domusonl...@gmail.com> wrote:
> Accordingly to the report, if you need to upgrade TODAY, then use xC6 and
> use the workaround (force the building of the SMI).
> If you upgrade after xC6W1 is available then use it and you won't need the
> workaround.
>
> Regards.
>
> On Fri, Jan 29, 2010 at 10:28 AM, Bartlomiej Lidke
>
>
>
> <ohggu...@rcs.cy.rot13.invalid> wrote:
> > Obnoxio The Clown <obno...@serendipita.com> wrote:
>
> >http://www-01.ibm.com/support/docview.wss?uid=swg21418229&myns=swgimg...
>
> > > /me bangs head on desk
>
> > try to find a 'recommended' word here:
>
> >http://www-01.ibm.com/support/docview.wss?uid=swg27014361#11.50
>
> > 11.50.xC5W4 = Superseded
> > 11.50.xC6 = Will be replaced by 11.50.xC6W1
> > 11.50.xC6W1 = Future release
>
> > :-(
>
> > --
> > butthead
> > _______________________________________________
> > Informix-list mailing list
> > Informix-l...@iiug.org
> >http://www.iiug.org/mailman/listinfo/informix-list
>
> --
> Fernando Nunes
> Portugal
>
> http://informix-technology.blogspot.com
> My email works... but I don't check it frequently...
Well even that is not ok..
IC64331 AFTER CONVERSION TO 11.50 THE ONCHECK -CC COMMAND REPORTS A
DISCREPANCY IN NEXT EXTENT SIZE FOR SOME SYSTEM CATALOG TABL
IC63942 IN-PLACE MIGRATION WITH AUDITING ACTIVE CAN LEAD TO ASSERTION
FAILURE:
PTALTSTAT2 BAD ALTER SLOT
IC64745 WHEN MIGRATING FROM 7.31.FD6 TO 11.50.FC5 WITH DATABASES PAGE
ZERO IS OVERWRITTEN
WITH PAGE 4 OR 5
IC64185 MIGRATION OF A FUNCTION RETURNS 211 ERROR ASSERT FAILS AND
CREATES
CORRUPTION IN THE SYSTEM CATALOG
IC60800 OUTPUT FILE CONTAINING ERRORS FROM VIOLATION TABLE CONVERSION
IS
OVERWRITTEN WHEN A SUBSEQUENT DATABASE IS CONVERTED
So upgradean can corrupt the system catalog three ways and cause some
errors to be missed.
IC63876 APPARENT RACE CONDITION WHEN BAR_MAX_BACKUP WORKER PROCESSES
RETURN PROCESSES OUT OF SEQUENCE
IC64918 ONTAPE THREAD CAN HANG IN PH_SUBMIT_TASK AFTER COMPLETING LOG
BACKUP
So version 11 allows parallel backups even on unlogged databases but
they do not work reliably, ontape log backups are not reliable
IC60893 IPLOAD CORE DUMPS ON 11.50
There are no details but HPL is not reliable
IC62958 CERTAIN ONAUDIT ERRORS CAN CAUSE RAPID INCREASE IN THE ONLINE
LOG SIZE HIGH
MEMORY CONSUMPTION AND EXTENSIVE ALARMPROGRAM CALL
IC61295 HUGE MEMORY PEAKS ON SYSTEM WITH LARGE NUMBER OF TABLES/
FRAGMENTS DESPITE MOST
AGGRESSIVE PTCLOSER CONFIGURATION
IC62299 SEQUENCE OBJECT USE IN A NON-LOGGING DATABASE CAN FILL LOGS
WITH UNIQ8ID
AND CAUSE LONG TRANSACTIONS WHEN USING NOCACHE OPTION
Three issues can cause resource overallocation
IC62244 ADDING LOGICAL LOGS AFTER A TRANSACTION REACHES LTXEHWM DOES
NOT RELEASE THE
SERVER FROM BLOCKED:LONGTX STATE
Logging can get stuck and is therefore not reliable.
IC64811 WHEN USING SQLTRACE SQL_RUNTIME SQL_TOTALTIME AND OTHER TIME
FIELDS ARE INCORRECT
SQL TRACE does not work
IC64908 ON STARTUP OF SERVER ON LINUX ONINIT PRINTS ERROR PID CANT GET
REAL PATH OF
Startup gives errors on Linux
IC63252 A STORED PROCEDURE CAN TAKE TOO LONG TO COMPLETE WHEN CALLING
NESTED PROCEDURES
Nested stored procs can be slow.
IC64421 AFTER RAISE EXCEPTION IN TRIGGER PROCEDURE A CONSTRAINT
VIOLATION IS APPLIED TO THE NEXT STATEMENT
Triggers with constraints do not work
IC64805 INSERT ROW FAILED IN MKROWID SQLERR RECEIVED -626
Inserts do not work!!
IC64937 WHEN ASSIGNING A STRING OF INCORRECT SIZE TO A VARCHAR
VARIABLE NO ERROR IS
RETURNED AND CAN LEAD TO MEMORY OVERFLOW
Memory overflows can occur and are not be trapped (I assume as with
all memory overflows this can cause server srashes)
IC62826 OPTIMIZER INCORRECTLY PERFORMS SEQUENTIAL SCAN ON TABLE
RESULTING IN SLOW QUERY TIME
Optimizer is broken
http://www-01.ibm.com/support/docview.wss?rs=0&uid=swg27014361
indicates that the next proper fully tested release will be 11.50.xC7
estimated for
Apr 12 and since fixpacks always seem to slip a month then that will
be beginning of May.
So 4 months to deploy, do all testing and upgrade before version 10
support ends..not good.
IBM NEED TO FIX ALL THE ABOVE ISSUES in 11.50.xC7 WITHOUT FAIL.
<david@smooth1.co.uk> wrote in message news:1756ee51-b3d3-4adf-97e9-6bf683c590b3@b10g2000yqa.googlegroups.com... On 29 Jan, 14:01, Fernando Nunes <domusonl...@gmail.com> wrote: > Accordingly to the report, if you need to upgrade TODAY, then use xC6 and > use the workaround (force the building of the SMI). > If you upgrade after xC6W1 is available then use it and you won't need the > workaround. >> Well even that is not ok.. <list of bugs> >> IBM NEED TO FIX ALL THE ABOVE ISSUES in 11.50.xC7 WITHOUT FAIL. Or else, you will do what? In v10, we are now quite stable ... in FC10! Here is one of the drawbacks of low useage of IDS; it takes a long time to learn lesssons that will be found only "in the field". This, I expect, is even worse in the "premium" products such as MACH11, which surely get very little use in "real-world" circumstances?
david@smooth1.co.uk wrote:
> On 29 Jan, 14:01, Fernando Nunes <domusonl...@gmail.com> wrote:
>> Accordingly to the report, if you need to upgrade TODAY, then use xC6 and
>> use the workaround (force the building of the SMI).
>> If you upgrade after xC6W1 is available then use it and you won't need the
>> workaround.
>>
>> Regards.
>>
>> On Fri, Jan 29, 2010 at 10:28 AM, Bartlomiej Lidke
>>
>>
>>
>> <ohggu...@rcs.cy.rot13.invalid> wrote:
>>> Obnoxio The Clown <obno...@serendipita.com> wrote:
>>> http://www-01.ibm.com/support/docview.wss?uid=swg21418229&myns=swgimg...
>>>> /me bangs head on desk
>>> try to find a 'recommended' word here:
>>> http://www-01.ibm.com/support/docview.wss?uid=swg27014361#11.50
>>> 11.50.xC5W4 = Superseded
>>> 11.50.xC6 = Will be replaced by 11.50.xC6W1
>>> 11.50.xC6W1 = Future release
>>> :-(
>>> --
>>> butthead
>>> _______________________________________________
>>> Informix-list mailing list
>>> Informix-l...@iiug.org
>>> http://www.iiug.org/mailman/listinfo/informix-list
>> --
>> Fernando Nunes
>> Portugal
>>
>> http://informix-technology.blogspot.com
>> My email works... but I don't check it frequently...
>
> Well even that is not ok..
>
>
> IC64331 AFTER CONVERSION TO 11.50 THE ONCHECK -CC COMMAND REPORTS A
> DISCREPANCY IN NEXT EXTENT SIZE FOR SOME SYSTEM CATALOG TABL
This will not happen in every system. And it's a discrepancy between
information in the systables and the real table layout
>
> IC63942 IN-PLACE MIGRATION WITH AUDITING ACTIVE CAN LEAD TO ASSERTION
> FAILURE:
> PTALTSTAT2 BAD ALTER SLOT
This requires a pre-version 9.x to be in-place migrated to v9.x and then
to v10 or v11.x. It will depend on the audit level used, and it will
depend on "bad luck" (thread running sequence, because the "issue" will
be fixed during conversion).
So it's not even v11 specific...
>
> IC64745 WHEN MIGRATING FROM 7.31.FD6 TO 11.50.FC5 WITH DATABASES PAGE
> ZERO IS OVERWRITTEN
> WITH PAGE 4 OR 5
Seems to be platform specific, but I can't be sure. In any case, it's
nice to see some work done related to non-supported versions (7.31).
>
> IC64185 MIGRATION OF A FUNCTION RETURNS 211 ERROR ASSERT FAILS AND
> CREATES
> CORRUPTION IN THE SYSTEM CATALOG
Happens converting v10 to v11..
>
> IC60800 OUTPUT FILE CONTAINING ERRORS FROM VIOLATION TABLE CONVERSION
> IS
> OVERWRITTEN WHEN A SUBSEQUENT DATABASE IS CONVERTED
>
Errors occurred during convertion of violating tables. These errors will
not happen most of the times.
> So upgradean can corrupt the system catalog three ways and cause some
> errors to be missed.
>
> IC63876 APPARENT RACE CONDITION WHEN BAR_MAX_BACKUP WORKER PROCESSES
> RETURN PROCESSES OUT OF SEQUENCE
The PMR was closed after some OS patches were installed. The problem
didn't happen again.
>
> IC64918 ONTAPE THREAD CAN HANG IN PH_SUBMIT_TASK AFTER COMPLETING LOG
> BACKUP
It CAN hang. Needs some specific thread schedule timmings. A debugger
was needed to rreproduce this...
>
> So version 11 allows parallel backups even on unlogged databases but
> they do not work reliably, ontape log backups are not reliable
>
> IC60893 IPLOAD CORE DUMPS ON 11.50
It will depend on the x-Server you use. I hit this one. It has a pretty
easy workaround (don't use 32bit color), but it can be a PITA to figure
what is happening. Several x-servers can handle the issues, others
don't. I'm happy to see we can fix it in the engine.
>
> There are no details but HPL is not reliable
>
> IC62958 CERTAIN ONAUDIT ERRORS CAN CAUSE RAPID INCREASE IN THE ONLINE
> LOG SIZE HIGH
> MEMORY CONSUMPTION AND EXTENSIVE ALARMPROGRAM CALL
I like this one. The interesting part of this is that the real issue has
nothing to to with onaudit... It should turn out to be an alarm
sub-system feature (or maybe bug). Some changes in the alarmprogram
could ease the situation but not solve it completely. The fact that it
can happen with other situations, makes me wonder how many times it
happened to each of us? Oh... and it's not 11.50 specific.
>
> IC61295 HUGE MEMORY PEAKS ON SYSTEM WITH LARGE NUMBER OF TABLES/
> FRAGMENTS DESPITE MOST
> AGGRESSIVE PTCLOSER CONFIGURATION
This is not a problem that causes resource overallocation. This
overallocation (assuming we accept its more than it should be) has seen
some features to decrease them. In some environments these features
apparently are not enough. Maybe the customer needs more hardware to
handle his database load. But R&D will keep trying... Notice that the
problem is not new. The solution is relatively new, and apparently in
some situation it's still not enough.
>
> IC62299 SEQUENCE OBJECT USE IN A NON-LOGGING DATABASE CAN FILL LOGS
> WITH UNIQ8ID
> AND CAUSE LONG TRANSACTIONS WHEN USING NOCACHE OPTION
This turned out to be expected behavior. In non-logged databases, some
activities must be logged... Sequences are one of them. In this
particular situation, the customer was doing an insert of 93M rows. Each
row will require a logical log entry. Without the NOCACHE, one entry
will take 20 sequence "steps". So without NOCACHE the logical log
activity was much (20x) higher.
>
> Three issues can cause resource overallocation
>
> IC62244 ADDING LOGICAL LOGS AFTER A TRANSACTION REACHES LTXEHWM DOES
> NOT RELEASE THE
> SERVER FROM BLOCKED:LONGTX STATE
This is "normal" behavior. The defect associated with the APAR is
classified as "feature". The behavior described is there since
DYNAMIC_LOGS was introduced. Now... If you ask me, I'd give my strong
vote for this feature. But it's nothing specific for v11 (except that a
possible fix/feature will only appear in some 11.x+ of course)
>
> Logging can get stuck and is therefore not reliable.
Logging has always been "stuckable" if you don't configure it properly.
No news here.
>
> IC64811 WHEN USING SQLTRACE SQL_RUNTIME SQL_TOTALTIME AND OTHER TIME
> FIELDS ARE INCORRECT
Hmmm... I've also seen this one. It was during test/benchmark phase of a
7.31 to 11.50 migration. It was inconvenient, but didn't stop me from
using SQLTRACE to show the customer what was the issue. They couldn't
solve it in the application (where the issue was generated), but some
engine tweaking was enough to overcome their doubts. Running happily on
11.50 for some months.
>
> SQL TRACE does not work
... at 100%
>
> IC64908 ON STARTUP OF SERVER ON LINUX ONINIT PRINTS ERROR PID CANT GET
> REAL PATH OF
>
In practice it's a cosmetic issue. It doesn't happen in every Linux box.
It's also the tip of an Iceberg (not related to IDS):
http://blogs.igalia.com/aperez/2009/01/the-story-of-linux-gatevdsoso/
IDS apparently is trying to call stat() on it...
> Startup gives errors on Linux
... on some systems, and then apparently works as expected.
Not sure why we do the stat(), and what happens when we can't do it...
>
>
> IC6325
De Stomerij wrote: > <david@smooth1.co.uk> wrote in message > news:1756ee51-b3d3-4adf-97e9-6bf683c590b3@b10g2000yqa.googlegroups.com... > On 29 Jan, 14:01, Fernando Nunes <domusonl...@gmail.com> wrote: >> Accordingly to the report, if you need to upgrade TODAY, then use xC6 and >> use the workaround (force the building of the SMI). >> If you upgrade after xC6W1 is available then use it and you won't need >> the >> workaround. > >>> Well even that is not ok.. > <list of bugs> >>> IBM NEED TO FIX ALL THE ABOVE ISSUES in 11.50.xC7 WITHOUT FAIL. > > Or else, you will do what? > > In v10, we are now quite stable ... in FC10! > > Here is one of the drawbacks of low useage of IDS; it takes a long time > to learn lesssons that will be found only "in the field". > > This, I expect, is even worse in the "premium" products such as MACH11, > which surely get very little use in "real-world" circumstances? > Complementing my answer to David: - I have customer running "quite stable" with 11.50 (FC5). - Regarding your observation about MACH 11, it depends. HDR and RSS are VERY common. ER is not so common. Connection Manager is becoming comming in anyone using HDR/RSS. This discussion remembers me of an epic discussion I, some people from a customer, and a consultant from a competitor had. This consultant was saying that a patch simply corrects a bug and never introduces other issues. I tried to reason with him, and I was followed by the customer team. No luck... He kept is view. Needless to say that since then, both me, and (specially) the customer had several situations where we reminded him of his now famous position... ;) Now, if a patch can bring nasty errors, of course new code can do the same. And, although we call it software "engineering", this is very far from the certainty we get in buildings, ships, planes, roads etc. (other forms of engineering) Regards.
"Fernando Nunes" <domusonline@gmail.com> wrote in message news:hk5i48$9ef$1@news.eternal-september.org... >> This, I expect, is even worse in the "premium" products such as MACH11, >> which surely get very little use in "real-world" circumstances? >> > > Complementing my answer to David: > > - I have customer running "quite stable" with 11.50 (FC5). > - Regarding your observation about MACH 11, it depends. HDR and RSS are > VERY common. ER is not so common. Connection Manager is becoming comming > in anyone using HDR/RSS. Yes, I should have not mentioned MACH11. Instead, I mean data compression and "continuous access feature" (CAF/"RAC"). Both these are, I believe, chargeable even on top of the Enterprise fee. Is the uptake high? I know of no-one using them.