Re: export fails with error : *** prepare unldobj
Posted in 2000
Note that myschema (in utils2-ak) has an option (-l) that causes it to
produce a dbimport compatible schema file. Then you can place all of your
manual unload files in a directory named <databasename>.exp, put the schema
there, and name the files according to the load commands to dbimport that
are embedded in the schema (or edit the schema to contain your filenames).
Then you will be able to use dbimport to reload (or myimport for that
matter) this is basically what myexport does.
Art S. Kagel
Tam McLaughlin wrote:
>
> Thanks for all the replies. Unfortunately, as time was running out, I had to
> do something
> and choose to unload each table via a script. This did work but will make
> the job of generating
> an import schema file harder but not impossible. DBA owns all the tables,
> and I have exported this
> databse recently without any problems. I did not try the -q option as I
> wanted to know what errors I was getting rather than ignoring them and
> the -o option is just for which directory to place the export.
> I will look at utils2_ak for next time (or rather, get familiar with them
> now so I can be more prepared)
>
> Tam McLaughlin wrote in message <8p8hqt$n1i$1@plutonium.btinternet.com>...
> >I am in a bit of a panic as I have to export our databases for tomorrow
> >morning
> >as our servers disks get replaced but I am getting an error on the exports.
> >I tried exporting 2 different databases and they both fall over with the
> >same
> >error at the same table. A sample from the dbexport.out file is below.
> >We are on sco unixware 7.0.1 with IDS 7.30.UC2.
> >I have tried :
> >dbexport -d databasename -ss -c> >
> >and without the -c and get same result
> >
> >
> >create table "dba".syscolformats
> > (
> > owner char(32),
> > tabname char(32),
> > .........
> > ...........
> >) extent size 16 next size 16 lock mode row;
> >revoke all on "dba".syscolformats from "public";> >
> >*** prepare unldobj
> >201 - A syntax error has occurred.
> >
> >Informix support have suggested the following options and cannot give me
> >any other
> >options/answer until tomorrow when it is too late.
> >
> >1. dbexport without -c option.
> >2. unload the table which caused the problem and drop it before you run
> >dbexport.
> >
> >1 does not nwork
> >
> >I think it would be better to run a script (which i am doing now) to give
> me
> >the
> >schema , and then to unload each table , 1 at a time and to an unload file
> >and try and
> >generate an import file from the schema files.
> >Any better ideas ?
> >
> >One other imporant thing, we are getting Assert failures as below:
> >
> >Cannot use TBLSpace page for TBLSpace 1048676
> >16:31:09 Action: Run 'oncheck -pt 1048676> >
> >however oncheck reports that the tablespace no does not exist. Informix
> >support believe it's
> >a temp table and that doing the export/import may fix the problem.
> >
> >
> >