Informix GLS functionality on RH6.0 Linux
Posted in 1999
Topics: Connectivity: ESQL/C, 4GL & Embedded SQL, Platform-Specific Issues, Internationalization & Character Sets
--------------63CB3D6B83B8383148CD3FFB
Content-Type: text/plain; charset=koi8-r
Content-Transfer-Encoding: 7bit
Hello , I've run 4gl program with preset:
DB_LOCALE=ru_ru.1251; Russian locale -it present in glfilesreport.(KOI-8 with same affect).
CLIENT_LOCALE=ru_ru.1251SERVER_LOCALE=ru_ru.1251
and get:
4gl run-time error number -23101
unable to load locale categories.
What's the matter? Is it something wrong or Linux platform not support
GLS ?
INFORMIXDIR setting is quite right...
I've use Dynamic server 7.30.UC7+last 4gl for linux platform.
Best regards. Andrey.
--------------63CB3D6B83B8383148CD3FFB
Content-Type: text/html; charset=koi8-r
Content-Transfer-Encoding: 7bit
<!doctype html public "-//w3c//dtd html 4.0 transitional//en">
<html>
Hello , I've run 4gl program with preset:
<br>DB_LOCALE=ru_ru.1251; Russian locale -it present in <b>glfiles </b>report.(KOI-8
with same affect).
<br>CLIENT_LOCALE=ru_ru.1251
<br>SERVER_LOCALE=ru_ru.1251
<br>and get:
<p>4gl run-time error number -23101
<br>unable to load locale categories.
<p>What's the matter? Is it something wrong or Linux platform not support
GLS ?
<br>INFORMIXDIR setting is quite right...
<br>I've use Dynamic server 7.30.UC7+last 4gl for linux platform.
<p>Best regards. Andrey.</html>
--------------63CB3D6B83B8383148CD3FFB--
Andrey Skvortsov wrote:
> Hello , I've run 4gl program with preset:
> DB_LOCALE=ru_ru.1251; Russian locale -it present in glfiles> report.(KOI-8 with same affect).
> CLIENT_LOCALE=ru_ru.1251> SERVER_LOCALE=ru_ru.1251
> and get:
>
> 4gl run-time error number -23101
> unable to load locale categories.
>
> What's the matter?
It appears to mean that the Russian locale you are asking for is
not installed on the machine. Have you checked under the GLS
subdirectory ($INFORMIXDIR/gls) to see whether the ru_ru
sub-directories exist? I don't recall seeing them during the
installs, but I confess it isn't something I've needed previously.
> Is it something wrong or Linux platform not support GLS ?
> INFORMIXDIR setting is quite right...
> I've use Dynamic server 7.30.UC7+last 4gl for linux platform.
You may need to install the Russian Language Supplement, assuming
there is such a thing.
> <!doctype html public "-//w3c//dtd html 4.0 transitional//en">
Please don't post HTML!
--
Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net)
Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN
#include <disclaimer.h>