Re: =?iso-8859-1?Q?Can=B4t_recreate_index_on_temp_tab?=
Posted in 2005
J?rg Spilker said:
> We're running Informix Dynamic Server 9.40.FC3 on a HP alpha cluster
> node. One of our applications is creating temp table's with indexes
> within a transaction. When the transaction is rolled back, the temp
> tables are gone. However if the application tries to recreate the temp
> tables and indexes in the same session, creating the indexes always
> fails with:
>
> SQL statement error number -242.
> Could not open database table (12spilk.t_tmp_fasumme)
> SYSTEM error number -106.
> ISAM error: non-exclusive access.>
> How can i avoid this problem?
Just a guess -- try explicitly dropping the temp table in the transaction.
--
Bye now,
Obnoxio
"C'est pas parce qu'on n'a rien ' dire qu'il faut fermer sa gueule"
- Coluche
"I'm trying to see things your way, but I can't get my head up my ass"
- JCH
"Ogni uomo mi guarda come se fossi una testa di cazzo"
- Marco
If anyone told you to be yourself they would be giving you bad advice.
I went to the airport to check in and they asked what I did because I
looked like a terrorist. I said I was a comedian. They said, "Say
something funny then." I told them I had just graduated from flying
school.
-- Ahmed Ahmed
sending to informix-list