RE: Any assistance greatly appreciated: [4079]
Posted in 2005
This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.
------_=_NextPart_001_01C50060.00C55540
Content-Type: text/plain
All,
I am now unable to reply individually to your emails, as I am receiving
quite a few.
I would like to thank you all, however no solutions have yet been
discovered, IBM Support have a wonderful message on their phone line at the
moment (well here in Australia and on the number I was given): "Due to
circumstances out of our control we are unable to accept your phone call at
the moment, please try again later.". That is really not what you want to
hear when the powers at be are jumping on you. (why are problems always
Friday afternoon ??? :) ...)
I have seen this error once before about 10 years or so ago and it was a
recoverable state I just cannot remember how it was achieved - I think it
was a simple matter of Informix logging in and setting a flag within the
root dbspace but in that I cannot get on to IBM it makes it difficult to
achieve.
I thank you all for your help this far, and will happily receive any and
all mails that may offer any sort of hope.
When a solution is found ( confidence :) ) I will post the solution so
at least it is in the archives so in 10 years when I have the problem again
at least it is noted somewhere :).
Thanks.
Cliff.
PS: Is the light at the end of the tunnel an on coming train? that's the
question!
_____
From: Burton, Clifford [mailto:clifford_burton@simplus.com.au]
Sent: Saturday, 22 January 2005 6:06 PM
To: Ravi T
Cc: informix-list@iiug.org
Subject: RE: Any assistance greatly appreciated: [4079]
Ravi,
Unfortunately the nature of the error isn't attributed to the memory
creation (the reference to the single shared memory segment merely states
that the allocation of 1.5Gb of memory exceeds the operating systems maximum
shared memory allocation and therefore is proceeding to create 2 memory
segments ~ there is an overhead to this but that is outside the realms of
this thread).
The actual problem is that the database instance will not initialise
with a message that the "checking database partition index failed" after a
cold restore. There is a curiosity with the informix log in so far as it
does not record that anything is wrong, it completes the physical and
logical restores and there are no more entries in the message log.
Thanks for your efforts, they are appreciated.
Cheers
Cliff.
_____
From: Ravi T [mailto:ravit29@yahoo.com]
Sent: Saturday, 22 January 2005 5:55 PM
To: Burton, Cli....
Subject: Re: Any assistance greatly appreciated: [4079]
You can do an ipcs and see if there is any hanging segments, if so then kill
them using the command ipcrm -m <segmentnumber>. Or you can use ps -eaf
|grep oninit and kill all the oninit processes and then confirm that no
segments are hanging using ipcs command. Then, try to bring the system up.
Remember, you should use the above commands, only if you have a single
instance housed in the box you are woking on. Otherwise you have to map the
memory segments to the instances and see that you are killing the correct
unused segments only prior to killing them or you will bring down all the
instances.
Check onstat -m and you will see that the memory segment it is complaining
about is listed there and you can compare that segment to the output from
ipcs to get a better idea.
Hope this helps.
"Burton, Cli...." <clifford_burton@simplus.com.au> wrote:
Hi All,
I have a situation where the IDS-731UD4 instance I run on HP-UX 11 is
failing after a cold restore.
I do not have time to perform another restore without serious business
ramifications.
The output from the log file is: the last lines:
09:47:30 Could not create single shared memory segment with resident and
non-re
sident partitions. Proceeding to create 2 shared memory segments instead.
09:47:32 Segment locked: addr=0xc1841000, size=683679744
Sat Jan 22 09:47:32 2005
09:47:32 Event alarms enabled. ALARMPROG =
'/apps/informix_ids/etc/ifx_alert.sh'
09:47:38 DR: DRAUTO is 0 (Off)
09:47:39 Dynamically allocated new message shared memory segment (size
1104KB)
09:47:39 Informix Dynamic Server Version 7.31.UD1 Software Serial Number
AAD
#J216570
09:47:39 Informix Dynamic Server Initialized -- Shared Memory Initialized.
09:47:39 Physical Recovery Started.
09:47:39 Physical Recovery Complete: 0 Pages Restored.
09:47:39 Logical Recovery Started.
09:47:42 Logical Recovery Complete.
0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
However:
informix@machinename$ onstat -shared memory not initialized for INFORMIXSERVER 'newworld'
The results of the oninit -v are:
Checking group membership to determine server run modesucceeded
Reading configuration file
'/apps/informix_ids/etc/onconfig.newworld'...succeeded
Creating /INFORMIXTMP/.infxdirs ... succeeded
Creating infos file "/apps/informix_ids/etc/.infos.newworld" ...
"/apps/informix_ids/etc/.conf.newworld" ... succeeded
Writing to infos file ... succeeded
Checking config parameters...succeeded
Allocating and attaching to shared memory...succeeded
Creating resident pool 143252 kbytes...succeeded
Creating buffer pool 524290 kbytes...succeeded
Initializing rhead structure...succeeded
Initializing ASF ...succeeded
Initializing Dictionary Cache and Stored Procedure Cache...succeeded
Bringing up ADM VP...succeeded
Creating VP classes...succeeded
Onlining 4 additional cpu vps...succeeded
Onlining 18 IO vps...succeeded
Forking main_loop thread...succeeded
Initialzing DR structures...succeeded
Forking 1 'ipcshm' listener threads...succeeded
Forking 2 'soctcp' listener threads...succeeded
Forking 1 'ipcshm' listener threads...succeeded
Forking 0 'soctcp' listener threads...succeeded
Forking 0 'soctcp' listener threads...succeeded
Starting tracing...succeeded
Initializing 32 flushers...succeeded
Initializing log/checkpoint information...succeeded
Opening primary chunks...succeeded
Opening mirror chunks...succeeded
Initializing dbspaces...succeeded
Validating chunks...succeeded
Initialize Async Log Flusher...succeeded
Forking btree cleaner...succeeded
Initializing DBSPACETEMP list
Checking database partition index...FAILED
oninit: Fatal error in shared memory initialization
I realise that it is unlikely that too many people are out there right at
this moment, however, I have been working on this issue so long now that I
am loosing track of time, Does anyone have any ideas as to how to get this
online, I do have a vague recollection of an issue like this in the past
that was resolved quite simply. I am attempting to contact IBM Support on
the issue although it is a moderately complex task out of hours when I
cannot locate the support contracts etc...
Clifford Burton
Senior Database Administrator
SIMplus Mobile Pty Ltd [ www.SIMplus.com.au ]
Ph: (02) 9028 1716
Fx: (02) 9030 6284
Mb: 0414 381 381@@N