More Archecker questions
Posted in 2000
Topics: Backup & Restore, Server Administration
okay -- I found a couple useful threads of discussion on archecker, one
from john dimisa posted 1/20/00 that gave some configuration info for
archecker. I found his hints in the Informix Backup and REstore Guide
Dec 1999 on the informix website as well. but it's only information
for archecker for onbar. And there is a one sentence reference to
archecker in Admin Guide for IDS 2000 and nothing in the Archive and
Backup Guide for IDS 2000.
So, is there any information on archecker out there as it pertains to
ontape??
Thanks in advance
Cynthia Vale
SAP R/3 Basis / Certified Informix DBA
Sent via Deja.com http://www.deja.com/
Before you buy.
Below are some instruction on how to use archecker with ontape. I hope they
help.
---jmiller
John Miller
Purpose
------
The archecker is designed to validate a level 0 archive without
impacting the production system, ensuring that all data required to
restore a system exists on the archive tapes in the correct format.
Features
--------
- Checks a level 0 archive after the archive has completed
- Verification need not be done on the machine hosting the OnLine
system.
- Minimal system resources are required, even for large archives.
- Restartable at tape level.
- Detects missing pages and indicates affected table(s).
- Can also verify data in similar fashion to oncheck -cd.
- Progress monitor
- Creation of the INFO directory give many usefull reports about the
archive.
Setup and Operation
-------------------
Set the environment variable AC_CONFIG to the name of your
configuration file. Otherwise $INFORMIXDIR/etc/ac_config.std is
used by default. If no valid config file is found, archecker will
print an error message and exit.
A sample configuration file:
----------------------------
AC_STORAGE .
AC_MSGPATH ./msg.log
AC_TAPEDEV /dev/rmt/0
AC_TAPEBLOCK 16
Valid Configuration file parameters
-----------------------------------
AC_STORAGE
The name of a directory where temporary files
are kept. The amount of space required is determined
by two factors: the number of chunks and the number of tables.
To give you a guide, a 50GB OnLine system should take about 20MB
(your mileage may vary).
DEFAULT: your current directory.
AC_MSGPATH
Pathname of archecker's message log. All error
and status messages will be placed in this file.
DEFAULT: ./msg.log
AC_TAPEDEV
Name of the tape device.
DEFAULT: NONE
AC_TAPEBLOCK
The size of the tape block in KB. It must match the
blocksize used for the archive, otherwise an error
will indicate the correct blocksize to use.
DEFAULT: NONE
AC_VERBOSE
0 Do not be verbose
1 Verbose output
DEFAULT 0
Command Line Usage
-----------------
archecker may be invoked by itself or with the following options:
-v Enables the verbose output
-d Cleanup any temporary files from a previous run.
-s Display the verbose message to the screen.
-t Use ontape tape device
-H to get a basic usage method
-R To restart at the last sync point (i.e. tape)
-V to get the current tool version
Recommend:
archecker -tdsv
Verbose Option
--------------
With the verbose option on, dots are to the screen--one
for every 25MB of data read from the tape. Each line of
dots represents 1GB of data. When the tape is changed,
cxvale66@my-deja.com wrote:
> okay -- I found a couple useful threads of discussion on archecker, one
> from john dimisa posted 1/20/00 that gave some configuration info for
> archecker. I found his hints in the Informix Backup and REstore Guide
> Dec 1999 on the informix website as well. but it's only information
> for archecker for onbar. And there is a one sentence reference to
> archecker in Admin Guide for IDS 2000 and nothing in the Archive and
> Backup Guide for IDS 2000.
>
> So, is there any information on archecker out there as it pertains to
> ontape??
>
> Thanks in advance
>
> Cynthia Vale
> SAP R/3 Basis / Certified Informix DBA
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
Informational/Welcome any comments.
archecker -tdvs works with ontape backups. I'm using HPUX 11.0 and
Informix v7.3uc10.
Now that it's working, I'm getting these partition errors in the
ac_msg.log:
ERROR: Unable to open a partition file
ERROR: Unable to open a partition file
ERROR: Unable to open a partition file
ERROR: Unable to open a partition file
ERROR: Exceeded the maximum number or errors (50000)
Error printing is suspended.
Archecker is still running. I saw discussion a thread that said maybe
these tables no longer exist in the database. One curious thing, I
have 12K + tables in the database, and there were 50K+ partition
errors. Must not be a one to one correspondence, unless it counts
fragments or extents? At the end of the checking process, the message
log:
STATUS: Table checks PASSED
STATUS: BLOBChunk checks PASSED
TIME: [03/29/2000 15:07:33] Checking Completed
STATUS: Tables/Fragments validated: 12357
Archive Validation Passed
Too bad it didn't list the particular patitions that errored out.
Check out the INFO and SAVE dirs. gives all table names and partnums.
lots of info there.
Cynthia Vale
SAP R/3 Basis / Certified Informix DBA
In article <38E21DCB.9F20402F@informix.com>,
John Miller <jmiller@informix.com> wrote:
> Below are some instruction on how to use archecker with ontape. I
hope they
> help.
>
> ---jmiller
> John Miller
>
> Purpose
> ------
> The archecker is designed to validate a level 0 archive without
> impacting the production system, ensuring that all data required to
> restore a system exists on the archive tapes in the correct format.
>
> Features
> --------
> - Checks a level 0 archive after the archive has completed
> - Verification need not be done on the machine hosting the OnLine
> system.
> - Minimal system resources are required, even for large archives.
> - Restartable at tape level.
> - Detects missing pages and indicates affected table(s).
> - Can also verify data in similar fashion to oncheck -cd.
> - Progress monitor
> - Creation of the INFO directory give many usefull reports about the
> archive.
>
> Setup and Operation
> -------------------
> Set the environment variable AC_CONFIG to the name of your
> configuration file. Otherwise $INFORMIXDIR/etc/ac_config.std is
> used by default. If no valid config file is found, archecker will
> print an error message and exit.
>
> A sample configuration file:
> ----------------------------
>
> AC_STORAGE .
> AC_MSGPATH ./msg.log
> AC_TAPEDEV /dev/rmt/0
> AC_TAPEBLOCK 16
>
> Valid Configuration file parameters
> -----------------------------------
>
> AC_STORAGE
> The name of a directory where temporary files
> are kept. The amount of space required is determined
> by two factors: the number of chunks and the number of tables.
> To give you a guide, a 50GB OnLine system should take about 20MB
> (your mileage may vary).
> DEFAULT: your current directory.
>
> AC_MSGPATH
> Pathname of archecker's message log. All error
> and status messages will be placed in this file.
> DEFAULT: ./msg.log
>
> AC_TAPEDEV
> Name of the tape device.
> DEFAULT: NONE
>
> AC_TAPEBLOCK
> The size of the tape block in KB. It must match the
> blocksize used for the archive, otherwise an error
> will indicate the correct blocksize to use.
> DEFAULT: NONE
>
> AC_VERBOSE
> 0 Do not be verbose
> 1 Verbose output
> DEFAULT 0
>
> Command Line Usage
> -----------------
> archecker may be invoked by itself or with the following options:
> -v Enables the verbose output
> -d Cleanup any temporary files from a previous run.
> -s Display the verbose message to the screen.
> -t Use ontape tape device
> -H to get a basic usage method
> -R To restart at the last sync point (i.e. tape)
> -V to get the current tool version
>
> Recommend:
> archecker -tdsv
>
> Verbose Option
> --------------
> With the verbose option on, dots are to the screen--one
> for every 25MB of data read from the tape. Each line of
> dots represents 1GB of data. When the tape is changed,
>
> cxvale66@my-deja.com wrote:
>
> > okay -- I found a couple useful threads of discussion on archecker,
one
> > from john dimisa posted 1/20/00 that gave some configuration info
for
> > archecker. I found his hints in the Informix Backup and REstore
Guide
> > Dec 1999 on the informix website as well. but it's only information
> > for archecker for onbar. And there is a one sentence reference to
> > archecker in Admin Guide for IDS 2000 and nothing in the Archive and
> > Backup Guide for IDS 2000.
> >
> > So, is there any information on archecker out there as it pertains
to
> > ontape??
> >
> > Thanks in advance
> >
> > Cynthia Vale
> > SAP R/3 Basis / Certified Informix DBA
> >
> > Sent via Deja.com http://www.deja.com/
> > Before you buy.
>
>
Sent via Deja.com http://www.deja.com/
Before you buy.