Re: Onbar imported restore fails
Posted in 2003
Well, you could check the storage manager logs but I'm guessing from
the behavior of onbar that they do not show anything. Sometimes these
could be a kernel issue, so make sure that your kernel settings are
what is recommended in the
"$INFORMIXDIR/release/en_us/0333/IDS_<version>" file. You could also
try setting BAR_DEBUG to 9 and seeing of there is any thing extra.
You didn't mention what operating system you are running on, but most
have a utility to record the messages between a process and the
operating system. For instance, on Solaris the utility is truss, and
it works similar to:
truss onbar -b -w -L 0 > truss.out
Have your OS vendor read the truss output. I know of someone who had
similar behavior to what you are seeing and trussed their onbar
process. They received an onbar return code 159 which is "BAR_BUG",
and has a case open with Informix support. The onbar return codes are
in the back of the Backup and Restore Guide (chapter 11?).
Good luck. Hope this information helps.
Brice Avila
"Colin Bull" <c.bull@videonetworks.com> wrote in message news:<bjplbc$gs1$1@terabinaries.xmission.com>...
> I have been doing an imported restore of 5 servers for 5 months without a
> problem.
> Recently I had a file system fail and my backup up scripts were not up to
> date, and
> I have had to modify them.
> Since then only 1 of the 5 restores has fails with the following error
>
> 2003-09-10 16:22:53 525941 525939 The ON-Bar process 526085 exited with a
> problem (exit code 255 (0xff), signal -1).
> 2003-09-10 16:24:03 526080 525941 ERROR: Unable to open connection to
> server:
> could not fork server connection.
>
> Previous threads on similar errors have suggested file permissions.
>
> I have checked all the files I can think of and they are all on long
> standing
> file systems. There is disk space on all file systems.
>
> I have run oninit -i using the same onconfig with only physdbs and number of
> logs changed,
> and that worked fine.
>
> The Online log is not being written to.
> With bar_debug set to 5 there is no output.
> If bar_debug is set to 7 there is 17MB in 27 minutes before an error shows
> in bar_act.log.
>
> Any suggestions of what else to check ?
>
> Colin Bull
> c.bull@videonetworks.com
>
> sending to informix-list