RE: Restricting users connecting from a certain host
Posted in 2000
The easiest is to configure jour firewall, if it can do so. Otherwise take my code from iiug {ISPY} and mod it to do no logging, and only allow your user to connect. Run it on your firewall. I acts as a gateway but is not yet ported to linux. Runs well on SUN, SCO 5+ and UNIXWARE. You can also do the same with ODBC if you uses Openlink ODBC diver installed on the firewall. Let me know If I can help. Time is limited. -----Original Message----- From: Guillermo Labatte [SMTP:labatteg@usa.net] Sent: Saturday, July 15, 2000 12:41 AM To: informix-list@iiug.org Subject: Restricting users connecting from a certain host Hi, I would like to know whether an Informix 7.X server running on Linux would be able to accept or reject a connection coming from a particular host depending on the user name supplied. The scenario is as follows. We want to setup an Informix database server behind a firewall. The server should accept all connections coming from the local network. However, we'd like to restrict the access from hosts outside the local network. We can easily do that configuring the firewall in a way that it rejects all connections to the port Informix is listening to. However, there's a particular host outside the firewall that should access the database. We would like to find the way of accepting connections to the database coming from that host, but only for a particular username (a user name that would be granted read privileges only). All attempts from other users in that host should be rejected. Is it possible? Thanks in advance, and apologies for my ban English. Guillermo Labatte