Error -951 when connecting as NIS user
Posted in 1999
Topics: Installation, Setup & Upgrades, Networking & sqlhosts Configuration, Versions, Editions & End-of-Life
Dear Informixers, hopefully some of you gurus out there are reading this newsgroup over the weekend. I just installed IDS 7.30UC3 on a Siemens RM400 running Reliant UNIX 5.43C20. Installation and loading of the databases went fine, but now I find that I can only connect to the database as a non-NIS user. When I try connecting as a user that is defined in NIS, I get refused with error -951: User username is not known on the database server. This happens with local connections over ipcshm as well as with remote connections via onsoctcp. The database server is also the NIS server, and I could not find anything wrong with the NIS setup (this has been unchanged for years). Until today, everything was working fine with Online 5.10. I didn't migrate the old server, but exported all databases, started up IDS with new partitions and imported the databases. I'm desperate! Everything worked on my test server, which was not partici- pating in NIS, but accepted network connections from NIS clients just fine. I need to go back into production with this system on Monday, so I need some advice FAST! I already searched the IIUG archives, but couldn't find a solution. I'll monitor this newsgroup closely, but I'd appreciate CCs via mail. Regards, Richard -- +--------------------------+------------------------------------------+ | Dr. Richard Spitz | INTERNET: spitz@ana.med.uni-muenchen.de | | EDV-Gruppe Anaesthesie | Tel : +49-89-7095-6110 <-- NEW! | | Klinikum Grosshadern | FAX : +49-89-7095-8886 | | 81366 Munich, Germany | GSM : +49-172-8933578 | +--------------------------+------------------------------------------+
Dear Informixers, meanwhile I've found the cause for my problem (with the help of Siemens support): In the "/etc/shadow" file, NIS users have a "0" in the "warn" field (see manpage for "shadow". This makes IDS believe that the login is no longer valid. Seems like an Informix bug to me, a bug report will be filed by Siemens support after further investigation. Workaround: Edit the "/etc/shadow" file so there will be a non-zero value (I used "7" like in the non-NIS accounts) in the "warn" field. I have no idea if this problem is specific to Reliant UNIX (the Siemens flavor of UNIX) or if it occurs on other platforms, too. Regards, Richard -- +--------------------------+------------------------------------------+ | Dr. Richard Spitz | INTERNET: spitz@ana.med.uni-muenchen.de | | EDV-Gruppe Anaesthesie | Tel : +49-89-7095-6110 <-- NEW! | | Klinikum Grosshadern | FAX : +49-89-7095-8886 | | 81366 Munich, Germany | GSM : +49-172-8933578 | +--------------------------+------------------------------------------+