Identically named instances, different hosts
Posted in 2000
Topics: Networking & sqlhosts Configuration, Platform-Specific Issues, Versions, Editions & End-of-Life
Is there a way to reference two different instances which have identical names but reside on different hosts? I have attempted to set up my sqlhosts file to do this, but the local informixserver refuses to run, complaining with Informix error #25572 and oserr 8 "Network driver cannot bind a name to the port." Is there a workaround for this? We're using IDS 7.31.UC-4 on Solaris2.7/Intel (don't ask).
You can't have two listener threads listening to the same port. You will need to create a second TCP alias which I think that you have done, however, it must have a differend port number. Red Valsen wrote: > Is there a way to reference two different instances which have identical > names but reside on different hosts? I have attempted to set up my > sqlhosts file to do this, but the local informixserver refuses to run, > complaining with Informix error #25572 and oserr 8 "Network driver > cannot bind a name to the port." Is there a workaround for this? > > We're using IDS 7.31.UC-4 on Solaris2.7/Intel (don't ask).
Red Valsen wrote:
> Is there a way to reference two different instances which have identical
> names but reside on different hosts? I have attempted to set up my
> sqlhosts file to do this, but the local informixserver refuses to run,
> complaining with Informix error #25572 and oserr 8 "Network driver
> cannot bind a name to the port." Is there a workaround for this?
>
> We're using IDS 7.31.UC-4 on Solaris2.7/Intel (don't ask).
My test instance didn't have any problems coming up after I renamed its
alias to match a remote server (9.21/HP11.00). dbaccess also did not have a
problem with the CONNECT option , though I wonder how it actually does it,
considering the CONNECT sql statement does not have any parameter
representing the host.
The Admin guide indicates that two identical DBServer names are allowed in
the sqlhosts file; however, only the first one would be used.
But wouldn't this be terribly confusing? Using DBAccess, you wouldn't be
sure which DBServer you'd be connecting to (until you actually see the list
of databases). I'd use DBSERVERALIAS to ensure uniqueness of DBServer in
sqlhosts.
Your 25572 error could be related to something more prosaic, like a
service not being defined in /etc/services.
Rudy