Re: Informix memory errors, 'serial' number errors
Posted in 1993
}From: uunet!cleveland.Freenet.Edu!ak132 (Felipe Barousse) }Subject: Informix memory errors, 'serial' number errors }Date: 14 Apr 1993 16:37:48 GMT }X-Informix-List-Id: <news.3043> }We have a DEC 433 MP with 3 CPU's, running SCO ODT 2.0 (which has Unix 3.2.4) }and Informix Online 5.0, Informix 4GL 4.1. }We have been experiencing some problems with a production 4GL program that }servers about 50 users at the same time on this machine. } }Are there any known problems if 4gl v4.1 is used with Online 5.0 ??? If so, }could you please describe what kind of troubles may arise. } }One of the errors we have is -408 that means "Invalid message type received }from the sqlexec process" That means the engine died. }Another error we have is -1113 which means "Memory allocation error", we are }not sure if this means a lack of shared memory, physical memory (i.e. real }memory) or virtual memory. The last two may not be the case since we have }64 MB of RAM and 4 GB of diskspace, the swap space is 65 MB. Memory error: what value is SHMBASE in tbconfig? Try increasing it in 4 MB increments (0x40000, 0x80000, ...). }The shared memory part of informix is configured for 60 users and indicates a }total of 1.6MB. The MAX shared mem size in the kernel configuration is 3.1MB }and 512 4K shared memory segments. } }I'd like to know opinions on this particular problem since we are not too }much involved with informix internals and there is the suspicion of a }memory fault (hardware), any ideas ??? } }On other issues, has any of you experienced problems with the 'serial' data }type on Informix. It seems to us that the supposed 'serial', never repeating; }incremental numbers are not working properly, they DO repeat. Has this }happened to someone else ? Please tell your story and how you solved it. }The configuration is the same described above. Serial Numbers: do you have a unique index on the serial column? There are two ways you can get duplicate values into a serial column. (1) You don't have a unique index on it (and an index isn't put there automatically unless you use the schema editor to create the table), you do INSERT INTO TableA VALUES (100, ...) twice. (2) You cycle past 2147483647 and the next number is 1. This doesn't normally happen -- if you inserted 1 row a second for 30+ years, you'd do it, but not before. Yours, Jonathan Leffler (johnl@obelix.informix.com) #include <disclaimer.h> ,