Help needed - Unable to start IDS 9.2
Posted in 2004
Topics: Error Codes & Troubleshooting, Logging & Checkpoints, Versions, Editions & End-of-Life
Hi!
I have a following problem on a windows xp machine runing IDS 9.2. The
database wouldn't start anymore after a power failure. I getting the
following errors in the log:
12:24:04 Informix Dynamic Server 2000 Initialized -- Shared MemoryInitialized.
12:24:04 Physical Recovery Started.
12:24:04 Physical Recovery Complete: 75 Pages Restored.
12:24:20 Logical Recovery Started.
12:25:07 Assert Failed: Rollback error 126
12:25:07 Informix Dynamic Server 2000 Version 9.20.TC4
12:25:07 Who: Session(8, informix@aopvirt, 0, 0)
Thread(14, fast_recvry, 0, 1)
File: rstrans.c Line: 2216
12:25:07 Results: Log record (OLDRSAM:HINSERT) in log 87, offset0x175428 was not rolled back
12:25:07 Action: Use 'onlog' to view the transaction and repair
manually.
12:25:07 stack trace for pid 396 written to C:\\tmp\\af.3f635e6
12:25:08 See Also: C:\\tmp\\af.3f635e6, shmem.3f635e6.0
12:25:13 Releasing server from system block
12:25:45 Rollback error 126
12:25:46 Assert Failed: Rollback error 126
12:25:46 Informix Dynamic Server 2000 Version 9.20.TC4
12:25:46 Who: Session(8, informix@aopvirt, 0, 0)
Thread(14, fast_recvry, 0, 1)
File: rsextlog.c Line: 1580
12:25:46 Results: Log record (OLDRSAM:HINSERT) in log 87, offset0x175428 was not rolled back
12:25:46 Action: Use 'onlog' to view the transaction and repair
manually.
12:25:46 stack trace for pid 396 written to C:\\tmp\\af.3f635e6
12:25:46 See Also: C:\\tmp\\af.3f635e6, shmem.3f635e6.1
12:26:31 Rollback error 126
12:26:31 Logical Logging error in 'rollback'
12:26:31 Assert Failed: Dynamic Server 2000 must abort
12:26:31 Informix Dynamic Server 2000 Version 9.20.TC4
12:26:31 Who: Session(8, informix@aopvirt, 0, 0)
Thread(14, fast_recvry, 0, 1)
File: rslog.c Line: 3194
12:26:31 Results: Dynamic Server 2000 must abort
12:26:31 Action: Reinitialize shared memory
12:26:32 stack trace for pid 396 written to C:\\tmp\\af.3f635e6
12:26:32 See Also: C:\\tmp\\af.3f635e6, shmem.3f635e6.2
12:27:20 PANIC: Attempting to bring system down
12:27:20 rslog.c, line 3194, thread 14, proc id 396, Dynamic Server2000 must abort.
Is there any way to correct/override this ? There are no backups so
restore can't solve the problem, and i'm not used to work with informix
databases so any help is wellcome.
Now as the database can't start the data can't be exported and as there
is no backup they afraid they will loose all data.
> Is there any way to correct/override this ? There are no backups so > restore can't solve the problem, and i'm not used to work with informix > databases so any help is wellcome. > Now as the database can't start the data can't be exported and as there > is no backup they afraid they will loose all data. Raise a call with IBM tech support. However, if you don't do backups you probably don't have support either. If tech support can't help for any reason I would imagine that yes, you will have lost all your data. regards Neil