"security subsysem" on NT with the AT program
Posted in 2000
Topics: Server Administration, Migration, Import/Export & Data Conversion
Hello everybody,
I have the following probleme with Informix 7.31.TC2, running on NT 4.0 SP5:
I am logged Adminisrator
When I lauch via an AT task a script with the informix environment (the
content of setenv.cmd), all informix command (dbaccess, onstat, dbexport)
return this error:
"Could not initialize the security subsystem. Please ensure that this
account has the necessary privileges"
My Informix and Administrator accounts have their Setnet32 params setted
correctly. (Ilogin32 logs fine)
However, during the execution of the script via AT, the variable USERNAME =
SYSTEM.
How setting the correct INFORMIX security environment for the user SYSTEM ?
Any idea ?
Thank you for your answer
Jean-Brice Albertus
jb.albertus@imsii.fr
You can change the Scheduler service to run as Administrator (or another
user). You cannot log in as SYSTEM - it is a special user for services.
The SYSTEM user gets its environment variables from the System Environment
Variables only and loads its registry hive from HKEY_USERS\\.DEFAULT.
To run the Scheduler as another user, go into the Control Panel and choose
Services, find the Scheduler service and click on it, then click on the
Startup button. Instead of running it as the System Account, you can choose
another user (click on the "..." button) and enter that user's password
twice and click OK. Then stop and start the service for it to take effect.
Note - if the selected user's password expires or changes, the scheduler
service will not start the next time you reboot. Ideally, you should create
a new user for the scheduler service and specify that the user's password
does not expire and cannot change. Then make sure that user is set up
properly to access the Informix database, then change the Scheduler service
to run as that user.
"Jean-Brice Albertus" <jbalbertus@imsii.fr> wrote in message
news:8qfnqo$on8$1@wanadoo.fr...
> Hello everybody,
>
> I have the following probleme with Informix 7.31.TC2, running on NT 4.0
SP5:
>
> I am logged Adminisrator
>
> When I lauch via an AT task a script with the informix environment (the
> content of setenv.cmd), all informix command (dbaccess, onstat, dbexport)
> return this error:
>
> "Could not initialize the security subsystem. Please ensure that this
> account has the necessary privileges"
>
> My Informix and Administrator accounts have their Setnet32 params setted
> correctly. (Ilogin32 logs fine)
>
> However, during the execution of the script via AT, the variable USERNAME
=
> SYSTEM.
>
> How setting the correct INFORMIX security environment for the user SYSTEM
?
>
> Any idea ?
>
> Thank you for your answer
>
> Jean-Brice Albertus
> jb.albertus@imsii.fr
>
>
>
>
>
Thank you everybody. Yours anwsers has helped me to fix this problem jba "Jean-Brice Albertus" <jbalbertus@imsii.fr> a 'crit dans le message news: 8qfnqo$on8$1@wanadoo.fr... > Hello everybody, > > I have the following probleme with Informix 7.31.TC2, running on NT 4.0 SP5: > > I am logged Adminisrator > > When I lauch via an AT task a script with the informix environment (the ... >