Informix installation problems on NT4-SP4
Posted in 1999
Topics: Installation, Setup & Upgrades
I just installed Informix Dynamic Server TNT Version 7.30.TC3-1 on a Windows NT4-SP4 server. After installing the software and rebooting the server, I got the following error on system startup: "SNMP.EXE: The procedure entry point SnmpSvcGetEnterpriseOID could not be located in the dynamic link library snmpapi.dll" I realize this is an error caused by the SNMP service, but it only occured after installing the Informix server. When I checked the NT event viewer I found this error: "The SNMP Service is ignoring extension agent dll C:\\WINNT\\System32\\Inetmib1.dll because it is missing or misconfigured" The PORTMAP service terminated on startup also. The (full) installation of Informix succeeded without a glitch. When I try to access the server using the IECC console it complains about some server detection failing. Has anyone had these same problems or does anyone have an idea of how to get the server running? TIA Silvio Bierman
Hi you may well find that sp4 reruns the network bindings for the TCP / IP settings and as part of that it will reload the default services file. If you edit \\\\winnt\\system32\\drivers\\etc\\services and put your service entry back in you may have some luck it is normally turbo 1526/tcp. With regards to the SNMP error I have got that error install ing 7.3 on sp3 machines as well. Silvio Bierman wrote: > I just installed Informix Dynamic Server TNT Version 7.30.TC3-1 on a Windows > NT4-SP4 server. After installing the software and rebooting the server, I > got the following error on system startup: > > "SNMP.EXE: The procedure entry point SnmpSvcGetEnterpriseOID could not be > located in the dynamic link library snmpapi.dll" > > I realize this is an error caused by the SNMP service, but it only occured > after installing the Informix server. When I checked the NT event viewer I > found this error: > > "The SNMP Service is ignoring extension agent dll > C:\\WINNT\\System32\\Inetmib1.dll because it is missing or misconfigured" > > The PORTMAP service terminated on startup also. > > The (full) installation of Informix succeeded without a glitch. > > When I try to access the server using the IECC console it complains about > some server detection failing. > > Has anyone had these same problems or does anyone have an idea of how to get > the server running? > > TIA > > Silvio Bierman
Hello, current Informix SW is not released for NT4 SP4. You will need IDS 7.30.TC7 for NT4 SP4. Silvio Bierman wrote: > I just installed Informix Dynamic Server TNT Version 7.30.TC3-1 on a Windows > NT4-SP4 server. After installing the software and rebooting the server, I > got the following error on system startup: > > "SNMP.EXE: The procedure entry point SnmpSvcGetEnterpriseOID could not be > located in the dynamic link library snmpapi.dll" > > I realize this is an error caused by the SNMP service, but it only occured > after installing the Informix server. When I checked the NT event viewer I > found this error: > > "The SNMP Service is ignoring extension agent dll > C:\\WINNT\\System32\\Inetmib1.dll because it is missing or misconfigured" > > The PORTMAP service terminated on startup also. > > The (full) installation of Informix succeeded without a glitch. > > When I try to access the server using the IECC console it complains about > some server detection failing. > > Has anyone had these same problems or does anyone have an idea of how to get > the server running? > > TIA > > Silvio Bierman -- Mit freundlichen Grüßen / with best regards :-) -\\|/- )ø^o( +=========oOOo==(_)==oOOo=======Mail-Client: Netscape V4.5==+ | Ernst Sauerwein Siemens ITService GmbH & Co. oHG| | =============== ISC-D 144 | | Microsoft Certified OLTP-Systems | | Professional INFORMIX® Database Support | | Tel: +49 89 3601 2699 Area South Europe | | FAX: +49 89 3601 2402 Berliner Str.95,III/C190-193 | | NERV: mailto:sauerwein.muc@sni.de | | EMAIL: mailto:ernst.sauerwein@mch.siemens.de | | EMAIL: mailto:ernsts@informix.com | | FTP: ftp://ftp.mch.sni.de/ (external) | | ftp://MB184060.mch.sni.de/ (internal) | | WWW: http://its.mch.sni.de/ (external) | | http://MB184060.mch.sni.de/ (internal) | +===========================================================+