Re: drop a column
Posted in 1999
The problem you've run into is the old-style ALTER behavior. In newer
versions, there is an in-place ALTER that runs faster and uses less disk space.
On the old version, however, the table is copied to a new table, with whatever
changes are specified by the ALTER statement. In your case, it is copying the
whole table except for the dropped column. After the copy, the original table
is dropped, and the new table is renamed to the original name. The dbspace
that is filling is the dbspace that holds the original table.
> I need to drop a column in a huge table( total 856941 rows and rows size 27).
To
> avoid long transaction, I set logging status to no logging. After load almost
> 20000 rows, I got the error:
> 222: Cannot write to temporary file for new table .
> 131: ISAM error: no free disk space>
> At the begining I thought maybe that was because temp dbspaces were full. But
> then I run again and found although temp
> dbspace is almost 360 MB empty all the time, I still got the same error. My
> question is: It use temp dbspaces or /tmp file system?
> In my config file, DBSPACETEMP already set to temp dbspaces. I am using
online
> 7.14 UD1 on HP-UX 10.20.
>
> Thanks in advance.
>
> Vivian
> vyao@dehavilland.ca