Could not write to a temporary file
Posted in 2009
Topics: Error Codes & Troubleshooting, Platform-Specific Issues, Versions, Editions & End-of-Life
[Informix][Dynamic Server 2000][trgokom] SQL Error(-264): Could not write to a temporary file. [ISAM error -131 : ISAM error: no free disk space] This error appears when I select from view which has 25 000 000 rows. What can I do to resolve this problem? IDS 10.00TC5E on Microsoft Windows Server 2003 EE !
Joshua wrote: > [Informix][Dynamic Server 2000][trgokom] SQL Error(-264): Could not > write to a temporary file. [ISAM error -131 : ISAM error: no free disk > space] > > This error appears when I select from view which has 25 000 000 rows. > What can I do to resolve this problem? > > IDS 10.00TC5E on Microsoft Windows Server 2003 EE ! Provide set explain on output? What is the view?
theBP wrote: > Joshua wrote: >> [Informix][Dynamic Server 2000][trgokom] SQL Error(-264): Could not >> write to a temporary file. [ISAM error -131 : ISAM error: no free disk >> space] >> >> This error appears when I select from view which has 25 000 000 rows. >> What can I do to resolve this problem? >> >> IDS 10.00TC5E on Microsoft Windows Server 2003 EE ! > > Provide set explain on output? > > What is the view? I create the view with SQL statement CREATE VIEW because I want the date from two tables. I try now with set explain.
If you select from a VIEW using a filter and the view was built with an ANSI '92 style SELECT statement, the IDS 10.00 engine will instantiate the VIEW to a temp table containing all 25,000,000 rows and apply the select to that temp table. That is why you have run out of temp space. Change the view to use the older Informix style SELECT or upgrade to IDS 11.50xC3 or later which fixed this problem. Art Art S. Kagel Oninit (www.oninit.com) IIUG Board of Directors (art@iiug.org) Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Oninit, the IIUG, nor any other organization with which I am associated either explicitly or implicitly. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Mon, May 25, 2009 at 9:23 AM, Joshua <josip.palcec@kr.htnet.hr> wrote: > theBP wrote: > > Joshua wrote: > >> [Informix][Dynamic Server 2000][trgokom] SQL Error(-264): Could not > >> write to a temporary file. [ISAM error -131 : ISAM error: no free disk > >> space] > >> > >> This error appears when I select from view which has 25 000 000 rows. > >> What can I do to resolve this problem? > >> > >> IDS 10.00TC5E on Microsoft Windows Server 2003 EE ! > > > > Provide set explain on output? > > > > What is the view? > > I create the view with SQL statement CREATE VIEW because I want the date > from two tables. I try now with set explain. > _______________________________________________ > Informix-list mailing list > Informix-list@iiug.org > http://www.iiug.org/mailman/listinfo/informix-list >
Related threads
- Re: oninit: Dictionary Cache and SPL Routine Cache error
- Re: oninit: Dictionary Cache and SPL Routine Cache error
- Help Needed in Phoenix
- INFORMIX 9.40 LINUX