SSD RAID selection
Posted in 2015
User asked whether to use RAID-5 or RAID-10 for an EMC SAN with SSDs for Informix dbspaces. EMC recommended RAID-5 (4+1), claiming modern SSD and enhanced storage systems eliminate traditional concerns. Database experts (Art Kagel and Lester Knutsen) strongly opposed RAID-5, arguing that drive failures cause slow rebuild times, performance degradation, I/O timeouts that take Informix offline, and cascading failures.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Performance & Tuning, Storage & Space Management
We are going to replace our existing SAN with a newer model EMC SAN. We are placing our dbspaces on SSD drives only. EMC recommended us to use storage pools with RAID-5 (4+1). We found that database forums are more in favor of RAID 10, if compare RAID 5 with 10 (strong recommendations by Art as well). We put those points before EMC team. Though they are not overriding the database experts opinion but they says according to orr data profiling and enhanced storage system of new SAN, RAID 5 is pretty much same in terms of reliability and performance in case of SSD drives. They ensures no bit rotting, and ignorable impact of parity calculation with new SAN (VNX 5400). We need database experts opinion on that matter. If enterprise level SSD and SAN storage have changed the rules, defined for spinning drives.
Simply two points: 1) RAID5 IS NOT SAFE. PERIOD. 2) NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! NO RAID5!!! Art Art S. Kagel, President and Principal Consultant ASK Database Management www.askdbmgt.com Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Wed, Jun 10, 2015 at 1:03 PM, KAMRAN HAQ <khaq@i2cinc.com> wrote: > We are going to replace our existing SAN with a newer model EMC SAN. We are > placing our dbspaces on SSD drives only. EMC recommended us to use storage > pools with RAID-5 (4+1). We found that database forums are more in favor of > RAID 10, if compare RAID 5 with 10 (strong recommendations by Art as well). > We put those points before EMC team. Though they are not overriding the > database experts opinion but they says according to orr data profiling and > enhanced storage system of new SAN, RAID 5 is pretty much same in terms of > reliability and performance in case of SSD drives. > They ensures no bit rotting, and ignorable impact of parity calculation > with > new SAN (VNX 5400). > We need database experts opinion on that matter. If enterprise level SSD > and > SAN storage have changed the rules, defined for spinning drives. > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --047d7bea35c05d88f805182d0a2b
Hi, We have a client using SSD on an newer EMC with RAID 10 and very happy with it. DO NOT USE RAID 5! no matter what they tell you. In my experience with RAID 5, even if it can recover a RAID 5 array your database will go down because of then length of time it takes to rebuild. With RAID 10 there is no recover time, no down time, it just keeps going. Regards - Lester On 6/10/15 1:03 PM, KAMRAN HAQ wrote: > We are going to replace our existing SAN with a newer model EMC SAN. We are > placing our dbspaces on SSD drives only. EMC recommended us to use storage > pools with RAID-5 (4+1). We found that database forums are more in favor of > RAID 10, if compare RAID 5 with 10 (strong recommendations by Art as well). > We put those points before EMC team. Though they are not overriding the > database experts opinion but they says according to orr data profiling and > enhanced storage system of new SAN, RAID 5 is pretty much same in terms of > reliability and performance in case of SSD drives. > They ensures no bit rotting, and ignorable impact of parity calculation with > new SAN (VNX 5400). > We need database experts opinion on that matter. If enterprise level SSD and > SAN storage have changed the rules, defined for spinning drives. > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > -- ______________________________________________________________________ Lester Knutsen lester@advancedatatools.com Advanced DataTools Corporation Voice: 703-256-0267 x102 Visit our Web page: http://www.advancedatatools.com ______________________________________________________________________
Thanks for the guidance. Can you please tell why would the database go down. For example if database is residing a (4+1) RAID 5 and one of the drives fails. Let's the drive to replace gets complete in X unit of time. is this that time cause some issue or anything else?
I'll back up what Lester said. The problem with the server possibly going offline when there is a RAID5 drive failure is twofold: 1. Until a replacement drive is assigned to be used to rebuild the down drive reads will be delayed while the SAN has to read all of the remaining drives to recreate data that resided on the failed drive if such data is requested. This process can be slow. Sometimes Informix will decide that the drive has failed if the reads take too long. The performance impact until recovery begins can be 25% or more for a five drive array. 2. Similarly once a replacement drive has been assigned, reading and writing will be slowed by as much as 80% in other words will be about five times slower than the full array. In this case it is more likely that Informix will determine that an IO has timed out and mark the offending chunks offline. I have seen both of these scenarios happen with EMC and others' arrays. Of course, since IO is so slow during recovery, recovery takes far longer for a lost RAID5 drive than it does for a lost RAID10 drive putting your system more at risk for a second drive failure before recovery completes which would be catastrophic and unrecoverable. Any problem that causes a drive failure is HIGHLY LIKELY to affect multiple drives. Why? Because if one drive has reached its physical lifetime limit and failed due to old age, then all of the other drives installed at the same time are likely in the same state and will also soon fail. If the drive has failed early then this is likely caused by a physical or firmware defect in the drive and any other drives from the same manufacturer's production lot will also be on the verge of experiencing an identical failure. In a RAID5 array, with five or more drives each dependent on the other, it is nearly impossible to have all of the drives coming from different production lots! In a RAID10 array you only have to worry that each member of a RAID1 pair is from a different lot and if you carefully mix in three or more production lots then the probability of a multiple drive failure causing catastrophic data loss is near zero whereas for RAID5 it is close to 100% in my opinion (and I'm not alone). As to EMC's comment that bit loss is not an issue, I will point to a study done by the physicists at CERN recently that proved that it is indeed a real issue for both magnetic drives and SSD drives. Just check out the comments on the membership list on the BAARF site: www.baarf.com/BAARF_members_sql.php you will see many instances of folks who, like me, have experienced RAID5 data loss. Art Art S. Kagel, President and Principal Consultant ASK Database Management www.askdbmgt.com Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Thu, Jun 11, 2015 at 11:59 AM, KAMRAN HAQ <khaq@i2cinc.com> wrote: > Thanks for the guidance. > Can you please tell why would the database go down. For example if > database is > residing a (4+1) RAID 5 and one of the drives fails. Let's the drive to > replace gets complete in X unit of time. is this that time cause some > issue or > anything else? > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --089e0116197a7f919d0518408052
If you are in the middle of a transaction, and the database needs to commit the data, and the write times-out because of RAID 5 failure, what happens ... and then if the rollback fails because of a write time-out, you are stuck with an inconsistent database. As a test, turn off one of your disk drives while data is being committed to it and then turn it back on and see what happens. Regards - Lester On 6/11/15 11:59 AM, KAMRAN HAQ wrote: > Thanks for the guidance. > Can you please tell why would the database go down. For example if database is > residing a (4+1) RAID 5 and one of the drives fails. Let's the drive to > replace gets complete in X unit of time. is this that time cause some issue or > anything else? > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > -- ______________________________________________________________________ Lester Knutsen lester@advancedatatools.com Advanced DataTools Corporation Voice: 703-256-0267 x102 Visit our Web page: http://www.advancedatatools.com ______________________________________________________________________