Prob: Drop Index & Cursor
Posted in 1998
Hello again, First let me thank all in this group for you past assistance. It has been much appreciated! Came across a new (for me!) problem last night, and cannot make heads or tails of the cause. System = HP 9000 running HP-UX 10.2 w/ Informix 7.24.UC3-1 (Dyn. Server) We have a daemon process (several actually) running with a declared cursor that just opens and closes as necessary (declared only once when daemon starts). This cursor access many tables. None of them are "sys" tables. Last night, I dropped an index on one of those tables and created a new index on that table. Nothing happened immediately as no users were on the syatem at the time. This morning, when users began hitting the system, the daemon cursor began trying to process, but failed on Opening. The error message was # 710. ISAM error 101. Here is what "finderr" returned: ----------------------------------------------------------------- -710 Table table-name has been dropped, altered, or renamed. After a statement has been prepared in the database server and before the user executes it, the table has been renamed or altered, possibly changing the structure of the table. Problems may occur as a result. ----------------------------------------------------------------- Why did this occur? Neither of the indexes were (a) unique or (b) clustered. Dropping and creating indexes shouldn't change the table at all, should it? Thanks much, Michael Hoffman