103 error
Posted in 2003
Topics: Platform-Specific Issues, Versions, Editions & End-of-Life
when I select a database,It return a 211 and ism code is 103,what is the matter? os:HP-UX 11i Informix: IDS 9.4 FC2W2 64 bit -- Posted via http://dbforums.com
I believe you should call your Informix technical support:
-211 Cannot read system catalog <error-text>.
The database server refers to the tables of the system catalog while it
processes most statements. When it cannot read one of these important
tables, a serious error results. Check the accompanying ISAM error code for
more information. The effect of the error depends on the statement that is
being executed and the particular table, as follows:
* CREATE TABLE statement, systabauth not read; the table is created,
but PUBLIC is not granted authorization as it normally is.
* DROP TABLE statement, systables not read; no action taken.
* DROP TABLE statement, sysviews not read; the table is dropped but
any views that depended on the table were not automatically dropped.
* DROP VIEW statement, sysviews not read; no action taken.
* DROP INDEX statement, sysindexes or systables not read; no action
taken.
* DROP SYNONYM statement, systables or syssynonyms not read; no
action taken.
* DROP DATABASE statement, systables not read; no action taken.
* START DATABASE statement, systables not read; no action taken.
* DATABASE statement, systables or sysusers not read; the database
was not selected (no current database; for subsequent operations, see
error -349).
Other statements might be partially complete before the error is detected.
Roll back the current transaction and then investigate the cause of the
error. Use the oncheck utility (secheck with INFORMIX-SE or tbcheck with
INFORMIX-OnLine) to check and repair indexes. If necessary, restore the
database from backup and logical-log tapes.
-----------------------------------------------
-103 ISAM error: illegal key descriptor (too many parts or too long).
The ISAM processor has been given an invalid key descriptor. For C-ISAM
programs, review the key descriptor. Each key descriptor has a maximum of 8
parts and 120 characters. If the error recurs, please refer to the Appendix
entitled "Trapping Errors" in your Administrator's Guide to acquire
additional diagnostics. Contact Informix Technical Support with the
diagnostic information.
-----------------------------------------------
Gorazd
"dusong" <member21945@dbforums.com> wrote in message
news:3499811.1066619052@dbforums.com...
>
> when I select a database,It return a 211 and ism code is 103,what is
>
> the matter?
>
> os:HP-UX 11i
>
> Informix: IDS 9.4 FC2W2 64 bit
>
> --
> Posted via http://dbforums.com