dbspace and table size
Posted in 2000
Topics: Storage & Space Management, Platform-Specific Issues
This message is in MIME format. Since your mail reader does not understand this format, some or all of this message may not be legible. ------_=_NextPart_001_01BFA97F.E89123F0 Content-Type: text/plain; charset="iso-8859-1" I am running into a small issue with one of our larger tables. We are running 7.24 UC3 on Solaris 2.6. The table has 33546106 rows and is 920 in size. There are 19 2 GIG chunks in this dbspace. 4 GIG are free. When trying to load data, I am getting an out of disk space error message. I have had this before and ended up purging out 6 months of old data and then things loaded perfectly fine. I am wondering if there is a size limit to a dbspace or table in Informix. I would appreciate any help in this matter. Thanks in advance. ------_=_NextPart_001_01BFA97F.E89123F0 Content-Type: text/html; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN"> <HTML> <HEAD> <META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; = charset=3Diso-8859-1"> <META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version = 5.5.2651.75"> <TITLE>dbspace and table size</TITLE> </HEAD> <BODY> <P><FONT COLOR=3D"#000080" SIZE=3D2 FACE=3D"Courier New">I am running = into a small issue with one of our larger tables. We are running = 7.24 UC3 on Solaris 2.6.</FONT> <BR><FONT COLOR=3D"#000080" SIZE=3D2 FACE=3D"Courier New">The table has = 33546106 rows and is 920 in size. There are 19 2 GIG chunks in = this dbspace. 4 GIG are free. When trying to load data, I = am getting an out of disk space error message. I have had this = before and ended up purging out 6 months of old data and then things = loaded perfectly fine. I am wondering if there is a size limit to = a dbspace or table in Informix. I would appreciate any help in = this matter. Thanks in advance.</FONT></P> <BR> </BODY> </HTML> ------_=_NextPart_001_01BFA97F.E89123F0--
"Farmer, Byrd G - CFC" wrote: > I am running into a small issue with one of our larger tables. We are > running 7.24 UC3 on Solaris 2.6. > The table has 33546106 rows and is 920 in size. There are 19 2 GIG chunks > in this dbspace. 4 GIG are free. When trying to load data, I am getting an > out of disk space error message. I have had this before and ended up > purging out 6 months of old data and then things loaded perfectly fine. I > am wondering if there is a size limit to a dbspace or table in Informix. I > would appreciate any help in this matter. Thanks in advance. The limits are way beyond the size of your current table. It appears that the table is alone in its dbspace. Its, therefore, unlikely that the max. no of extents limit has been reached. Check if your problem is related to the detached indexes - its possible that they reside in dbspaces near capacity. Its also possible that your indexes have reached the maximum allowable extents (in which case rebuilding [disable/enable] may help). Rudy
>Subject: dbspace and table size
>From: "Farmer, Byrd G - CFC" Farmer.Byrd@cfwy.com
>Date: 18.04.00 23:49 W. Europe Daylight Time
>Message-id: <8dincc$rqm$1@news.xmission.com>
>
>
>This message is in MIME format. Since your mail reader does not understand
>this format, some or all of this message may not be legible.
>
>------_=_NextPart_001_01BFA97F.E89123F0
>Content-Type: text/plain;
> charset="iso-8859-1"
>
>I am running into a small issue with one of our larger tables. We are
>running 7.24 UC3 on Solaris 2.6.
>The table has 33546106 rows and is 920 in size. There are 19 2 GIG chunks
>in this dbspace. 4 GIG are free. When trying to load data, I am getting an
>out of disk space error message. I have had this before and ended up
>purging out 6 months of old data and then things loaded perfectly fine. I
>am wondering if there is a size limit to a dbspace or table in Informix. I
>would appreciate any help in this matter. Thanks in advance.
>
>
>
>------_=_NextPart_001_01BFA97F.E89123F0
>Content-Type: text/html;
> charset="iso-8859-1"
>Content-Transfer-Encoding: quoted-printable
>
><!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
>
><HEAD>
><META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
>charset=3Diso-8859-1">
><META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
>5.5.2651.75">
><TITLE>dbspace and table size</TITLE>
></HEAD>
>
>
>
>I am running =
>into a small issue with one of our larger tables. We are running =
>7.24 UC3 on Solaris 2.6.
>
>The table has =33546106 rows and is 920 in size. There are 19 2 GIG
>chunks in =this dbspace. 4 GIG are free. When trying to load
>data, I =am getting an out of disk space error message. I have had this
>=before and ended up purging out 6 months of old data and then things =loaded
>perfectly fine. I am wondering if there is a size limit to =a dbspace
>or table in Informix. I would appreciate any help in =this
>matter. Thanks in advance.
>
>------_=_NextPart_001_01BFA97F.E89123F0--
>
>
>
>
>
>
check the number of extents that the table currently has. Should the number
extents be getting critical, think about unloading and re-loading the table
with onunload or ipload.
Nona
Farmer, Byrd G - CFC wrote: First, please do not post HTML/MIME messages to this list/newsgroup. > I am running into a small issue with one of our larger tables. We are > running 7.24 UC3 on Solaris 2.6. > The table has 33546106 rows and is 920 in size. There are 19 2 GIG chunks Also known as ~32GB or ~16million pages. Look in the release notes in IDS_7.2 you will see that the size limit for a single fragment of a table, and therefore for any unfragmented table, is 16,216,3xx pages (damned if I remember to the page). You have three choices: 1)Break up the table, 2) fragment the table, 3) detach all the indexes which will buy you a LITTLE time. Art S. Kagel > in this dbspace. 4 GIG are free. When trying to load data, I am getting an > out of disk space error message. I have had this before and ended up > purging out 6 months of old data and then things loaded perfectly fine. I > am wondering if there is a size limit to a dbspace or table in Informix. I > would appreciate any help in this matter. Thanks in advance. -- Art S. Kagel & Family kagel@erols.com
Related threads
- Conversion to differeent characters sets
- Problem in changing locale via dbexport/dbimport
- RE: openlink error "Unable to load locale categories"