ONBAR error: File not found: /fs/dbqa/dump/bar_act.log
Posted in 2003
Topics: Backup & Restore, Server Administration, Platform-Specific Issues, Versions, Editions & End-of-Life
Hi, I am Oracle DBA, new to Informix. I am learning Informix as I go, so please bear with me. I create a new database server called "onqadb". (IDS 9.3 on AIX 4.3). I used ISM to create the database server. When I clicked on ON-BAR on the left nav bar, I only see the error. I see the file on the server: -rw-rw---- 1 root sys 1918 Oct 13 16:44 bar_act.log -rw-rw-r-- 1 root sys 2092 Oct 13 17:21 onqadb.log ---------- The error I am getting is due to the permissions/ownership or something else? Appreciate your help! --Sree -- Posted via http://dbforums.com
sree_oradba wrote: > I am Oracle DBA, new to Informix. I am learning Informix as I go, so > please bear with me. > > I create a new database server called "onqadb". (IDS 9.3 on AIX 4.3). > > I used ISM to create the database server. When I clicked on ON-BAR on > the left nav bar, I only see the error. I see the file on the server: > > -rw-rw---- 1 root sys 1918 Oct 13 16:44 bar_act.log > -rw-rw-r-- 1 root sys 2092 Oct 13 17:21 onqadb.log > > The error I am getting is due to the permissions/ownership or > something else? It isn't completely clear. However, the answer probably lies in the ONCONFIG file, $INFORMIXDIR/etc/$ONCONFIG, and especially in the line for the BAR_ACT_LOG parameter. If you're normal, then you have specified that the bar_act.log file should go in $INFORMIXDIR, or maybe you've been careful to specify that it should go in the dump sub-directory of $INFORMIXDIR (but why is it /fs/dbqa instead of /fs/qadb or /fs/onqadb if it is housing the onqadb server?). The onqadb.log is often placed in $INFORMIXDIR (that's another parameter in ONCONFIG, much nearer the top - MESSAGEFILE or some such), though that's fairly bad practice and I always place my log in a sub-directory (and the console log is also sent to a file in the same sub-directory - and the debug and activity logs for ON-Bar, and so on). So, I suspect you have a discrepancy between the two locations. However, you may already have resolved that - or be showing us the correct locations. In which case, we need to start wondering why these files are all owned by group sys, rather than group informix as usual? That may point to a mis-installation of some sort, or an accidental collision of group informix with group sys, or ... goodness only knows what other alternatives there are. I'd expect the files to be owned by user informix, but user root is also a semi-plausible alternative. The group should pretty much definitively be group informix, so you may well have a simple permissions or ownership problem, as you hypothesized. You can check the correct permissions on the files by looking at the files lists in $INFORMIXDIR/etc (IDS2000files or IIFfiles, depending on exactly what you've got). You can compare what's in that file with what you've got on disk. There's a tool in the IIUG (International Informix User Group) Software Archive called utils_jl which contains ixchkperm and ixsetperm - they may be of some help in checking the permissions (though they're also pretty old and I've not tested them this millennium). Can you really use ISM to create the database server? ISA - Informix Server Administrator - might do it, but I don't think ISM - Informix Storage Manager - can do that. Finally, just to get you started in the right way, thank you for including the approximate version information (IDS 9.3, AIX 4.3) but please include the complete version information in future (IDS 9.30.UC6, AIX 4.3.3). All the digits and letters in the IDS version number can be significant - not likely in this case, but don't take the change in future, please. -- Jonathan Leffler #include <disclaimer.h> Email: jleffler@earthlink.net, jleffler@us.ibm.com Guardian of DBD::Informix v2003.04 -- http://dbi.perl.org/