Re: ONLOAD problem revisited ...
Posted in 2000
"Jeffrey P. Medeiros" wrote:
>
> Thanks to all the help I received from this newsgroup, I was able to figure
> out the proper syntax for the ONLOAD and ONUNLOAD utilities. The fact that
> the output file has to exist for the "onunload" to work really through me
> for a loop.
>
> However, I'm still having problems loading data I received from an outside
> source who is using IDS Version 7.30.UC7 (output of onunload -V), and I'm
> using IDS 7.30.UC2.
>
> Would this "UC" version mismatch account for the problems I'm having with
> the onload ?
Yes it could. You should also check the page sizes are the same.
> I'm able to load a test "onunload" file that I created into my database, but
> am unable to load the external data I received, using the same syntax as the
> test file. The error message is "Incorrect tape type", which seems to be a
> generic error message, since it occurs for a number of other syntax errors
> I've made. I've made sure the table doesn't exist for both tests, and only
> the "real" data seems to have a problem. I've also checked to make sure the
> data didn't get corrupted during the ftp by doing a checksum on both files
> (the one I have, and the original).
The external data should at the very least come from an IDS system with
the same page size as yours. Otherwise, you will have to transfer the
data using one of the ASCII utilities.
Cheers,
--
Mark.
+----------------------------------------------------------+-----------+
| Mark D. Stock mailto:mdstock@mydas.freeserve.co.uk |//////// /|
| http://www.informix.com http://www.informixhandbook.com |///// / //|
| http://www.iiug.org +-----------------------------------+//// / ///|
| |What year 2000 bug? year 2000 bug? |/// / ////|
| |year 2000 bug? year 2000 bug? year |// / /////|
| |2000 bug? year 2000 bug? year 1900 |/ ////////|
+----------------------+-----------------------------------+-----------+