Enterprise Replication on NT Servers
Posted in 2000
Topics: High Availability & Replication, Installation, Setup & Upgrades
I am trying to invoke Enterprise Replication between two IDS.2000 installations on Win NT Server 4.0 SP5. The two NTs are in separate domains, and the ER is defined for primary - target replication. ER will start without errors on the Primary server, g_sierra, but when I try to bring up ER on the target, g_sierra_m, I receive the error: Start of ER on g_sierra_m failed with error 5 (unable to connect to server specified). The NT event log shows the following: CDR connection to server lost, id 100, name <g_sierra> Reason: ASF connect error (7). Searching thru the docs, the FAQ, and Informix IDN have turned up nothing regarding ASF errors. What is ASF connect error 7, and more important, what am I doing wrong? Any help and/or advice is greatly appreciated.
ASF error 7 means that you has some type of connection rejection. Let's start with a simpler task first. You need to be able to log onto each of the instances and be able to connect to the other database without having to enter the user/password. The informix userid must be trusted between the two instances. It is critical that the SQLHOST portion of the registery be set up correctly for ER to function. If we take a typical sqlhost file for an ER system on NT, we might see somthing like: ---------------------------------- g_sierra group - - i=10 g_sierra_m group - - i=20 sierra olsoctcp host_sierra host_sierra_serv g=g_sierra sierra_m olsoctcp host_sierra host_sierra_m_serv g=g_sierra_m --------------------------------- However, the registery would need to look like: ---------------------------------------- REGEDIT4 [HKEY_LOCAL_MACHINE\\SOFTWARE\\Informix\\SQLHOSTS] [HKEY_LOCAL_MACHINE\\SOFTWARE\\Informix\\SQLHOSTS\\g_sierra] "HOST"="-" "OPTIONS"="i=10" "PROTOCOL"="group" "SERVICE"="-" [HKEY_LOCAL_MACHINE\\SOFTWARE\\Informix\\SQLHOSTS\\g_sierra\\sierra] [HKEY_LOCAL_MACHINE\\SOFTWARE\\Informix\\SQLHOSTS\\g_sierra_m] "HOST"="-" "OPTIONS"="i=20" "PROTOCOL"="group" "SERVICE"="-" [HKEY_LOCAL_MACHINE\\SOFTWARE\\Informix\\SQLHOSTS\\g_sierra_m\\sierra_m] [HKEY_LOCAL_MACHINE\\SOFTWARE\\Informix\\SQLHOSTS\\sierra] "HOST"="host_sierra" "OPTIONS"="g=g_sierra" "PROTOCOL"="olsoctcp" "SERVICE"="host_sierra_serv" [HKEY_LOCAL_MACHINE\\SOFTWARE\\Informix\\SQLHOSTS\\sierra_m] "HOST"="host_sierra" "OPTIONS"="g=g_sierra_m" "PROTOCOL"="olsoctcp" "SERVICE"="host_sierra_m_serv" ------------------------------- I'm going to be emailing you a little utility program that will convert the registery to/from the text sqlhost file format. This utility was available in one of the demo libraries as part of the IECC product. You should also be able to get this from tech support if necessary. A couple of other things to consider. You still need the service number of the remote instance contained in Winnt\\system32\\drivers\\etc\\services. Also, you may need to put in the remote system's tcp address in the host file since it is in a different domain. (I'm not sure if this is really necessary. Guess I'm showing some NT ignorance.) I've also had to set up a hosts.equiv in Winnt\\system32\\drivers\\etc\\hosts.equiv. Again I'm not totally sure that this is necessary. Hope some of this helps. I'm just about to head on a vacation so I don't know if/when I'll be able to respond to any of your replys. News wrote: > I am trying to invoke Enterprise Replication between two IDS.2000 > installations on Win NT Server 4.0 SP5. The two NTs are in separate domains, > and the ER is defined for primary - target replication. ER will start > without errors on the Primary server, g_sierra, but when I try to bring up > ER on the target, g_sierra_m, I receive the error: Start of ER on g_sierra_m > failed with error 5 (unable to connect to server specified). The NT event > log shows the following: CDR connection to server lost, id 100, name > <g_sierra> Reason: ASF connect error (7). > > Searching thru the docs, the FAQ, and Informix IDN have turned up nothing > regarding ASF errors. > What is ASF connect error 7, and more important, what am I doing wrong? Any > help and/or advice is greatly appreciated.