RE: deleting table from dropped dbspace
Posted in 2006
Topics: Backup & Restore, Storage & Space Management, Error Codes & Troubleshooting, Migration, Import/Export & Data Conversion
2 issues with that.
1 - The ontape -r -D never got to the point of asking about applying
llogs. (after 13 hours of running)
2 - Rolling forward the llogs would again delete the data from the
tables in question.
Thanks,
Randy
-----Original Message-----
From: informix-list-bounces@iiug.org
[mailto:informix-list-bounces@iiug.org] On Behalf Of Superboer
Sent: Monday, December 11, 2006 8:03 AM
To: informix-list@iiug.org
Subject: Re: deleting table from dropped dbspace
You have to rollforward your trx log when restoreing using ontape -r
-D...
see manual. this will bring you back where you were when the tables had
all data deleted!!!!!!!!!!! if you do not rollforward your logs then
your dbspace will be inconsistent. do it again and rollforward your logs
to get out of this mess.
eq make sure that your dbspace is consistent.
to get data back you can use archecker to do a table level restore.
have a look in the manual howto.
Superboer.
BTW search for table level restore, there was a howto recently
Kennedy, Randy schreef:
> Informix: 9.40FC3
> O/S: HPUX 11.11
>
> We had a need to restore 2 tables that had all data deleted so we
> attempted a ontape -r -D dbspacename. However, after 13 hours, it
> never completed (or errored out) so we just cut our losses and dropped
> and recreated the tables (only had ~8 tables in it and we had unloads
> of most of them) in another dbspace and the dbspace was dropped and
> recreated. As it turns out, there was one table that didn't get
> dropped and recreated and now it is not letting me drop it and I can't
> update statistics now either as it gives 2 errors: 215 "cannot open> file for table" and 135 "ISAM error: TBLSpace does not exist".
>
> How do I drop this table so I can recreate it in another dbspace?
>
> Thanks,
> Randy
>
>
> ------_=_NextPart_001_01C71D32.B3BE918A
> Content-Type: text/html
> Content-Transfer-Encoding: quoted-printable
> X-Google-AttachSize: 1803
>
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> <HTML><HEAD> <META http-equiv=Content-Type content="text/html;
> charset=us-ascii"> <META content="MSHTML 6.00.2900.2769"
> name=GENERATOR></HEAD> <BODY> <DIV><SPAN
> class=808273614-11122006><FONT face=Tahoma size=2>Informix:
> 9.40FC3</FONT></SPAN></DIV>
> <DIV><SPAN class=808273614-11122006><FONT face=Tahoma size=2>O/S: HPUX
> 11.11</FONT></SPAN></DIV> <DIV><SPAN class=808273614-11122006><FONT
> face=Tahoma size=2></FONT></SPAN> </DIV> <DIV><SPAN
> class=808273614-11122006><FONT face=Tahoma size=2>We had a need to
> restore 2 tables that had all data deleted so we attempted a ontape -r
> -D dbspacename. However, after 13 hours, it never completed (or
> errored out) so we just cut our losses and dropped and recreated the
> tables (only had ~8 tables in it and we had unloads of most of
> them) in another dbspace and the dbspace was dropped and
> recreated. As it turns out, there was one table that didn't get
> dropped and recreated and now it is not letting me drop it and I can't
> update statistics now either as it gives 2 errors: 215 "cannot open> file for table" and 135 "ISAM error: TBLSpace does not
> exist".</FONT></SPAN></DIV> <DIV><SPAN class=808273614-11122006><FONT
> face=Tahoma size=2></FONT></SPAN> </DIV> <DIV><SPAN
> class=808273614-11122006><FONT face=Tahoma size=2>How do I drop this
> table so I can recreate it in another dbspace?</FONT></SPAN></DIV>
> <DIV><SPAN class=808273614-11122006></SPAN> </DIV>
> <DIV><FONT face="Comic Sans MS"
> size=2><STRONG>Thanks,</STRONG></FONT></DIV>
> <DIV><FONT face="Comic Sans MS"
> size=2><STRONG>Randy</STRONG></FONT></DIV>
> <DIV> </DIV></BODY></HTML>
>
> ------_=_NextPart_001_01C71D32.B3BE918A--
_______________________________________________
Informix-list mailing list
Informix-list@iiug.org
http://www.iiug.org/mailman/listinfo/informix-list
Hello Randy,
> 1 - The ontape -r -D never got to the point of asking about applying
> llogs. (after 13 hours of running)
Why, what is the error, have you talked to Tech Support???
this could be a bug.... if so then a major bug!!
You may need to talk to them anyway, maybe they can hack your instance
so you can get rid of the inconsistent dbspace and problem tables.
So your first priority is getting your dbspace consistant.
> 2 - Rolling forward the llogs would again delete the data from the
> tables in question.
Yes that is how it should work. use archecker instead to do a table
level point in time
restore or goto a testbox and to a restore everything there; then
bring that engine online and
unload what you need.
Superboer.
Kennedy, Randy schreef:
> 2 issues with that.
> 1 - The ontape -r -D never got to the point of asking about applying
> llogs. (after 13 hours of running)
> 2 - Rolling forward the llogs would again delete the data from the
> tables in question.
>
> Thanks,
> Randy
>
> -----Original Message-----
> From: informix-list-bounces@iiug.org
> [mailto:informix-list-bounces@iiug.org] On Behalf Of Superboer
> Sent: Monday, December 11, 2006 8:03 AM
> To: informix-list@iiug.org
> Subject: Re: deleting table from dropped dbspace
>
> You have to rollforward your trx log when restoreing using ontape -r
> -D...
> see manual. this will bring you back where you were when the tables had
> all data deleted!!!!!!!!!!! if you do not rollforward your logs then
> your dbspace will be inconsistent. do it again and rollforward your logs
> to get out of this mess.
> eq make sure that your dbspace is consistent.
>
> to get data back you can use archecker to do a table level restore.
> have a look in the manual howto.
>
> Superboer.
>
> BTW search for table level restore, there was a howto recently
>
> Kennedy, Randy schreef:
>
> > Informix: 9.40FC3
> > O/S: HPUX 11.11
> >
> > We had a need to restore 2 tables that had all data deleted so we
> > attempted a ontape -r -D dbspacename. However, after 13 hours, it
> > never completed (or errored out) so we just cut our losses and dropped
>
> > and recreated the tables (only had ~8 tables in it and we had unloads
> > of most of them) in another dbspace and the dbspace was dropped and
> > recreated. As it turns out, there was one table that didn't get
> > dropped and recreated and now it is not letting me drop it and I can't
>
> > update statistics now either as it gives 2 errors: 215 "cannot open> > file for table" and 135 "ISAM error: TBLSpace does not exist".
> >
> > How do I drop this table so I can recreate it in another dbspace?
> >
> > Thanks,
> > Randy
> >
> >
> > ------_=_NextPart_001_01C71D32.B3BE918A
> > Content-Type: text/html
> > Content-Transfer-Encoding: quoted-printable
> > X-Google-AttachSize: 1803
> >
> > <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> > <HTML><HEAD> <META http-equiv=Content-Type content="text/html;
> > charset=us-ascii"> <META content="MSHTML 6.00.2900.2769"
> > name=GENERATOR></HEAD> <BODY> <DIV><SPAN
> > class=808273614-11122006><FONT face=Tahoma size=2>Informix:
> > 9.40FC3</FONT></SPAN></DIV>
> > <DIV><SPAN class=808273614-11122006><FONT face=Tahoma size=2>O/S: HPUX
>
> > 11.11</FONT></SPAN></DIV> <DIV><SPAN class=808273614-11122006><FONT
> > face=Tahoma size=2></FONT></SPAN> </DIV> <DIV><SPAN
> > class=808273614-11122006><FONT face=Tahoma size=2>We had a need to
> > restore 2 tables that had all data deleted so we attempted a ontape -r
>
> > -D dbspacename. However, after 13 hours, it never completed (or
> > errored out) so we just cut our losses and dropped and recreated the
> > tables (only had ~8 tables in it and we had unloads of most of
> > them) in another dbspace and the dbspace was dropped and
> > recreated. As it turns out, there was one table that didn't get
> > dropped and recreated and now it is not letting me drop it and I can't
>
> > update statistics now either as it gives 2 errors: 215 "cannot open> > file for table" and 135 "ISAM error: TBLSpace does not
> > exist".</FONT></SPAN></DIV> <DIV><SPAN class=808273614-11122006><FONT
> > face=Tahoma size=2></FONT></SPAN> </DIV> <DIV><SPAN
> > class=808273614-11122006><FONT face=Tahoma size=2>How do I drop this
> > table so I can recreate it in another dbspace?</FONT></SPAN></DIV>
> > <DIV><SPAN class=808273614-11122006></SPAN> </DIV>
> > <DIV><FONT face="Comic Sans MS"
> > size=2><STRONG>Thanks,</STRONG></FONT></DIV>
> > <DIV><FONT face="Comic Sans MS"
> > size=2><STRONG>Randy</STRONG></FONT></DIV>
> > <DIV> </DIV></BODY></HTML>
> >
> > ------_=_NextPart_001_01C71D32.B3BE918A--
>
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list