Re: RE: Informix : Bladelet Exec causes IDS Engine to crash !!
Posted in 2004
This is interesting (from the links) you can try something like:
select current, sqrt(1+2)::char(5)
from table( set {1} )
better than using dual isnt it?
but:
select current, sqrt(1+2)::char(5), set{1,2}
from table( set {1} )
returns an error, and I'm sure that's my fault but:
select current, sqrt(1+2)::char(5), set{1,2}::lvarchar
from table( set {1} )
core-dumped dbaccess instead of returning some kind of error.
even more interesting...
Chucho!
-----Original Message-----
From: "Paul Watson" <paul.watson@visitv.com>
To: "mkadmi" <moezmkadmi@yahoo.fr>, <informix-list@iiug.org>
Date: Mon, 23 Aug 2004 14:24:02 +0100
Subject: RE: Informix : Bladelet Exec causes IDS Engine to crash !!
Incorrect casting of the returned multiset can cause the blade to crash
Paul Watson
VISiTV
Tel: 01382 341074
Fax: 01382 341045
Mob: 07818 003457
> -----Original Message-----
> From: owner-informix-list@iiug.org
> [mailto:owner-informix-list@iiug.org] On Behalf Of mkadmi
> Sent: 23 August 2004 10:27
> To: informix-list@iiug.org
> Subject: Informix : Bladelet Exec causes IDS Engine to crash !!
>
>
> Hello,
>
> I use the Bladelet Exec to execute Dynamic Sql from SPL, I
> downloaded it from :
> http://www-106.ibm.com/developerworks/db2/zones/informix/libra
ry/demo/ids_exec.html
but after some hours of use it causes the IDS 9.30 Server to crash. Here
is the message in online.log :
16:48:34 Assert Failed: No Exception Handler
16:48:34 Informix Dynamic Server Version 9.30.FC3
16:48:34 Who: Session(189, import@a31c2e6, 308, 514221928)
Thread(211, sqlexec, c00000001ea3e480, 1)
File: mtex.c Line: 420
16:48:34 Results: Exception Caught. Type: MT_EX_OS, Context: mem
16:48:34 Action: Please notify Informix Technical Support.
16:48:34 stack trace for pid 2265 written to /tmp/af.4bb0f41
16:48:34 See Also: /tmp/af.4bb0f41, shmem.4bb0f41.0
16:49:26 Logical Log 25520 Complete.
16:50:18 mtex.c, line 420, thread 211, proc id 2265, No Exception
Handler. 16:50:19 The Master Daemon Died 16:50:20 PANIC: Attempting to
bring system down 16:50:20 semctl: errno = 22 16:50:20 semctl: errno =
22 ...
I compiled this DataBlade under HP-UX 11.11 on a L3000 HP 4 processors
Server having 4 Go of memory.
Now it's turned off to avoid these several crashs, but it is very
usefull to me to execute dynamic sqls.
Can you tell me if this is common to this function ?
Is there a solution to this problem ?
Is there a new version or a commertial versionof this bladelet ?
Thanks .
sending to informix-list
Jean Sagi
jeansagi@myrealbox.com
jeansagi@yahoo.com
sending to informix-list