Re: informix and web logic
Posted in 2005
We had similar problem. Resolution was to set Weblogic setting called "Test reserve connection" to "SQL: SET LOCK MODE TO WAIT n". You can use any SQL statement here if you prepend it with "SQL:". Gorazd <tomcaml@yahoo.com> wrote in message news:1121807004.814893.290030@o13g2000cwo.googlegroups.com... > hello > > we are running infx 9.40 FC3 on HP-UX 11i. Developers use web logic to > process batch files (JDBC drivers) - and they use connection pooling. > when i create a new DB in dev from Prod data, i start from scratch and > then rename DB's, for example DB1 becomes DB1_old and the DB1_new is > renamed to DB1, and then developers use the DB1 database. last thing i > do is run update stats on each table , proc and view and the whole db. > most tables are empty of data > > > what happens is they go to write to tables in the new DB and their > application returns an error of -244 "Could not do a physical-order > read to fetch next row. " > > they ask me to re-run update stats and they reset their server > connections to the database. has anyone run into this? it does not seem > that the update stats really change anything for them but rather the > re-setting of their connections....any help is appreciated > > Thanks > Tom >