Help needed : Version 5.x and 7.22 interwork
Posted in 1997
Friends,
I have a problem connecting version 5.x clients via Informix STAR to OnLine
7.22 database.
Version 7.22 will always use GLS, while Version 5.x has no concept of it.
The problem is that
aplication and data in database is in ISO8859-2 locale. I can not create
database without GLS
support, and if I set GLS locale to anything other than ISO8859-2 I get
syntax error on SQL statements
containing characters in upper half of ISO table (even in literal strings).
However, when I define
database with nchar columns then applications accessing data from version 5
client are not able to
see it. All nchar colmns are returned as empty strings, and when looking at
tables with version 5
of dbaccess I only see garbled symbols. I tried to contact Informix
technical support, but so far
I got no answer.
Has anyone encountered similra problems, or knows a workaround.
Thanks in advance
Slobodan Zorko
Alfatec Group