RE: the SYSTEM command within NT
Posted in 2001
Topics: Stored Procedures & SPL, Server Administration
Sounds like access rights on the bat file.
Peter
__________________________________
Peter Marley
Data Warehouse Developer, Acco Europe
Tel: +44 (0)1296 732184
Fax: +44 (0)1296 732185
email: peter.marley@acco-uk.co.uk <mailto:peter.marley@acco-uk.co.uk>
-----Original Message-----
From: Sean Kelsey [SMTP:seank@marketinfoserv.com]
Sent: Thursday, January 11, 2001 12:20 PM
To: informix-list@iiug.org
Subject: the SYSTEM command within NT
Good afternoon Informixers
IIF.2000 on NT 4.0 (and Win2000 Professional)
I am having a little difficulty in extracting the information I need
from
the OnLine manuals and would appreciate some pointers from an
experienced
individual.
As user JonDoe I connect to the database and create the following
simple
procedure to execute a system batch file:-
CREATE PROCEDURE jd_test()
SYSTEM 'c:\\dba_bin\\jd_test.bat'; END PROCEDURE;
which creates fine. If I now try and run the procedure it reports
back error
"668 - System Command can not be executed error 1 - Not owner".
However, if
I connect to the database as Informix it executes without a problem.
Can any
of you NT bods out there direct me to the cause and solution ?
Thanks as always;
S.
No, already checked that. The bat file is owned by JohnDoe, yet informix can
execute the procedure fine. JohnDoe can't.
I have read in the manual about NT platforms, making sure that the following
Advanced User Rights have been assigned to user "infromix":
Act as part of the operating system
Increase Quotas
Replace a process level token
but unfortunately in Win2000 this doesn't work - I can't find where to set
Advanced User Rights !!!
This is doing my co-co in !!
Thanks for the response anyway !!
S.
"Marley, Peter" <peter.marley@acco-uk.co.uk> wrote in message
news:93km67$arp$1@news.xmission.com...
>
> Sounds like access rights on the bat file.
>
> Peter
> __________________________________
> Peter Marley
> Data Warehouse Developer, Acco Europe
> Tel: +44 (0)1296 732184
> Fax: +44 (0)1296 732185
> email: peter.marley@acco-uk.co.uk <mailto:peter.marley@acco-uk.co.uk>
>
>
>
> -----Original Message-----
> From: Sean Kelsey [SMTP:seank@marketinfoserv.com]
> Sent: Thursday, January 11, 2001 12:20 PM
> To: informix-list@iiug.org
> Subject: the SYSTEM command within NT
>
> Good afternoon Informixers
>
> IIF.2000 on NT 4.0 (and Win2000 Professional)
>
> I am having a little difficulty in extracting the information I need
> from
> the OnLine manuals and would appreciate some pointers from an
> experienced
> individual.
>
> As user JonDoe I connect to the database and create the following
> simple
> procedure to execute a system batch file:-
>
> CREATE PROCEDURE jd_test()> SYSTEM 'c:\\dba_bin\\jd_test.bat';
> END PROCEDURE;
>
> which creates fine. If I now try and run the procedure it reports
> back error
> "668 - System Command can not be executed error 1 - Not owner".
> However, if
> I connect to the database as Informix it executes without a problem.
> Can any
> of you NT bods out there direct me to the cause and solution ?
>
> Thanks as always;
>
> S.
>
>
>
>
>