onload - onunload
Posted in 2017
Topics: Storage & Space Management, Migration, Import/Export & Data Conversion
IDS 11.50.FC5
Solaris 10
I created an onunload copy of a database on a server. The original database is
housed in two difference dbspaces, a 2k and an 8k.
Questions
Does the unload contain any dbspace information? How does it know to send the
tables to the different dbspaces?
If I specify a dbspace with -d that is 2k pages, it appears to want to put
everything there.
If I specify the dbspace that is 8k pages, I receive an error message after a
while.
If I do not specify a dbspace, it appears to fill up the rootdbs.
Larry
From the manual
<quote>
Because the tape that onload reads contains binary data that is stored in
disk-page-sized units, the computers where the original database resides
(where you use onunload) and where the target database will reside (where
you use onload) must have the same page size, the same representation of
numeric data, the same byte alignment for structures and unions.
.....
If the page sizes are different, onload fails.
</quote>
Sounds like you are trying to change the page size between the unload and
load
Cheers
Paul
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of LARRY
SORENSEN
Sent: Tuesday, February 14, 2017 2:03 PM
To: ids@iiug.org
Subject: onload - onunload [38630]
IDS 11.50.FC5
Solaris 10
I created an onunload copy of a database on a server. The original database
is
housed in two difference dbspaces, a 2k and an 8k.
Questions
Does the unload contain any dbspace information? How does it know to send
the
tables to the different dbspaces?
If I specify a dbspace with -d that is 2k pages, it appears to want to put
everything there.
If I specify the dbspace that is 8k pages, I receive an error message after
a
while.
If I do not specify a dbspace, it appears to fill up the rootdbs.
Larry
****************************************************************************
***
Forum Note: Use "Reply" to post a response in the discussion forum.
I have the proper dbspaces and pagesizes created. I seem to just be having
trouble getting the onload to go to the right two dbspaces.
Larry
________________________________
From: ids-bounces@iiug.org <ids-bounces@iiug.org> on behalf of Paul Watson
<paul@oninit.com>
Sent: Thursday, February 16, 2017 7:35 AM
To: ids@iiug.org
Subject: RE: onload - onunload [38649]
>From the manual
<quote>
Because the tape that onload reads contains binary data that is stored in
disk-page-sized units, the computers where the original database resides
(where you use onunload) and where the target database will reside (where
you use onload) must have the same page size, the same representation of
numeric data, the same byte alignment for structures and unions.
......
If the page sizes are different, onload fails.
</quote>
Sounds like you are trying to change the page size between the unload and
load
Cheers
Paul
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of LARRY
SORENSEN
Sent: Tuesday, February 14, 2017 2:03 PM
To: ids@iiug.org
Subject: onload - onunload [38630]
IDS 11.50.FC5
Solaris 10
I created an onunload copy of a database on a server. The original database
is
housed in two difference dbspaces, a 2k and an 8k.
Questions
Does the unload contain any dbspace information? How does it know to send
the
tables to the different dbspaces?
If I specify a dbspace with -d that is 2k pages, it appears to want to put
everything there.
If I specify the dbspace that is 8k pages, I receive an error message after
a
while.
If I do not specify a dbspace, it appears to fill up the rootdbs.
Larry
****************************************************************************
***
Forum Note: Use "Reply" to post a response in the discussion forum.
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
Larry,I just want to share you my experience working with onunload/onload in
the past, and #3 seems to answer to your question.
1. If you have table1 in dbs1, table2 in dbs2, etc. and table1's index in
idx1dbs, and so forth -- onload will reload everything into one dbspace and of
course if you don't specify one, it will go to rootdbs.
2. However, if your table1 is partitioned or fragmented into dbs1, dbs2, dbs3;
onload will automagically reload table1 in dbs1, dbs2, and dbs3 -- you just
make sure your target instance has those dbspaces or else your load will fail.
3. If tables in your database reside in different dbspaces with different page
sizes, onunload "appears" to work, but it will fail when you do the onload.
4. onload appears to fix the extent of a highly extent fragmented table. For
example, if your table1 has 160 extents, you will do onunload of table1,
onload it, then check to see if it still has 160? probably not.
5. There is an issue and I dont know if its still true in versions higher than
7, that when an instance that has a dbspace consisting of chunks with sizes 2G
or smaller while this instance has a table assigned with >2GB as its first
extent, then the newly onloaded database can later experience a problem with
onbar/ontape backup. Kern --
Let's go GreenThis email contains 100% recycled electrons.
From: LARRY SORENSEN <LSORENSEN25@msn.com>
To: ids@iiug.org
Sent: Thursday, February 16, 2017 10:40 AM
Subject: Re: onload - onunload [38650]
I have the proper dbspaces and pagesizes created. I seem to just be having
trouble getting the onload to go to the right two dbspaces.
Larry
________________________________
From: ids-bounces@iiug.org <ids-bounces@iiug.org> on behalf of Paul Watson
<paul@oninit.com>
Sent: Thursday, February 16, 2017 7:35 AM
To: ids@iiug.org
Subject: RE: onload - onunload [38649]
>From the manual
<quote>
Because the tape that onload reads contains binary data that is stored in
disk-page-sized units, the computers where the original database resides
(where you use onunload) and where the target database will reside (where
you use onload) must have the same page size, the same representation of
numeric data, the same byte alignment for structures and unions.
.......
If the page sizes are different, onload fails.
</quote>
Sounds like you are trying to change the page size between the unload and
load
Cheers
Paul
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of LARRY
SORENSEN
Sent: Tuesday, February 14, 2017 2:03 PM
To: ids@iiug.org
Subject: onload - onunload [38630]
IDS 11.50.FC5
Solaris 10
I created an onunload copy of a database on a server. The original database
is
housed in two difference dbspaces, a 2k and an 8k.
Questions
Does the unload contain any dbspace information? How does it know to send
the
tables to the different dbspaces?
If I specify a dbspace with -d that is 2k pages, it appears to want to put
everything there.
If I specify the dbspace that is 8k pages, I receive an error message after
a
while.
If I do not specify a dbspace, it appears to fill up the rootdbs.
Larry
****************************************************************************
***
Forum Note: Use "Reply" to post a response in the discussion forum.
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
ON-Load and ON-Unload are old and don't handle blobs fully.
They almost certainly don't handle different dbspaces with different page
sizes properly.
Most people do not use them very often at all.
On Thu, Feb 16, 2017 at 7:40 AM, LARRY SORENSEN <LSORENSEN25@msn.com> wrote:
> I have the proper dbspaces and pagesizes created. I seem to just be having
> trouble getting the onload to go to the right two dbspaces.
>
> ________________________________
>
> >From the manual
>
> <quote>
> Because the tape that onload reads contains binary data that is stored in
> disk-page-sized units, the computers where the original database resides
> (where you use onunload) and where the target database will reside (where
> you use onload) must have the same page size, the same representation of
> numeric data, the same byte alignment for structures and unions.
> .......
> If the page sizes are different, onload fails.
> </quote>
>
> Sounds like you are trying to change the page size between the unload and
> load
>
>
> IDS 11.50.FC5
>
> Solaris 10
>
> I created an onunload copy of a database on a server. The original database
> is
>
> housed in two difference dbspaces, a 2k and an 8k.
>
> Questions
>
> Does the unload contain any dbspace information? How does it know to send
> the
>
> tables to the different dbspaces?
>
> If I specify a dbspace with -d that is 2k pages, it appears to want to put
> everything there.
>
> If I specify the dbspace that is 8k pages, I receive an error message after
> a
>
> while.
>
> If I do not specify a dbspace, it appears to fill up the rootdbs.
>
--
Jonathan Leffler <jonathan.leffler@gmail.com> #include <disclaimer.h>
Guardian of DBD::Informix - v2015.1101 - http://dbi.perl.org
"Blessed are we who can laugh at ourselves, for we shall never cease to be
amused."
--001a1140e1926c67c90548b205f2