failed to backup logical logs
Posted in 2000
Dear IDS users,
Recently I installed IDS 7.31 on Windows NT 4.0 SP 5 .
I am able to create a database; next I tried with DBimport to load
databases.
Soon the logical logfiles are full and therefore the server is blocked
during taking a checkpoint.
I tried to backup the logical log with "onbar -l". This command seems to
fail.
Still the logical logs are not freed and the server stays blocked.
How can I free the logical logs and what is wrong with my "onbar" command?
Thanks
vanloon@wxs.nl
< onstat -a>
Informix Dynamic Server Version 7.31.TC4 -- On-Line (CKPT REQ) -- Up
06:11:32 -- 9536 Kbytes
Blocked:CKPT
18:17:02 Informix Dynamic Server Version 7.31.TC4 Software Serial NumberAAC#J810402
18:17:04 Informix Dynamic Server Initialized -- Shared Memory Initialized.
18:17:04 Physical Recovery Started.
18:17:04 Physical Recovery Complete: 3 Pages Restored.
18:17:04 Logical Recovery Started.
18:17:07 Logical Recovery Complete. 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
18:17:08 Dataskip is now OFF for all dbspaces
18:17:08 Init operation complete - Mode Online
18:17:08 On-Line Mode
18:17:19 Logical Log Files are Full -- Backup is Needed
Physical Logging
Buffer bufused bufsize numpages numwrits pages/io
P-1 0 8 0 0 0.00
phybegin physize phypos phyused %used
10003f 500 27 0 0.00
Logical Logging
Buffer bufused bufsize numrecs numpages numwrits recs/pages pages/io
L-1 1 8 1 1 1 1.0 1.0
Subsystem numrecs Log Space used
OLDRSAM 1 32
Buffer Waiting
Buffer ioproc flags
L-1 c19a018 0x1 0
address number flags uniqid begin size used %used
c039be4 1 U------ 1 100233 125 125 100.00
c039c00 2 U------ 2 1002b0 125 125 100.00
c039c1c 3 U------ 3 10032d 125 125 100.00
c039c38 4 U------ 4 1003aa 125 125 100.00
c039c54 5 U------ 5 100427 125 125 100.00
c039c70 6 U------ 6 1004a4 125 125 100.00
c039c8c 7 U------ 7 100521 125 125 100.00
c039ca8 8 U------ 8 10059e 125 125 100.00
c039cc4 9 U------ 9 10061b 125 40 32.00
c039ce0 10 U---C-L 10 100698 125 125 100.00
Profile
dskreads pagreads bufreads %cached dskwrits pagwrits bufwrits %cached
20 24 200 90.00 6 6 5 0.00
isamtot open start read write rewrite delete commit
rollbk
26 6 8 6 0 0 0 0 0
gp_read gp_write gp_rewrt gp_del gp_alloc gp_free gp_curs
0 0 0 0 0 0 0
ovlock ovuserthread ovbuff usercpu syscpu numckpts flushes
0 0 0 3.90 1.07 0 2
bufwaits lokwaits lockreqs deadlks dltouts ckpwaits compress seqscans
7 0 20 0 0 0 0 0
ixda-RA idx-RA da-RA RA-pgsused lchwaits
0 0 0 0 0
<Logfile onbar>
2000-01-16 18:05:34 224 224 F:\\informix\\bin\\onbar_d -l
2000-01-16 18:05:34 224 224 Begin backup logical log 1.
2000-01-16 18:05:36 224 224 Successfully connected to Storage Manager.
2000-01-16 18:05:36 224 224 XBSA Error (BSACreateObject): A system error
occurred. Aborting XBSA session.
2000-01-16 18:05:36 224 224 WARNING: The logical logs are full. ON-Bar
may encounter errors writing to the sysutils database.
2000-01-16 18:06:53 208 208 F:\\informix\\bin\\onbar_d -l
2000-01-16 18:06:53 208 208 Begin backup logical log 1.
2000-01-16 18:06:55 208 208 Successfully connected to Storage Manager.
2000-01-16 18:06:55 208 208 XBSA Error (BSACreateObject): A system error
occurred. Aborting XBSA session.
2000-01-16 18:06:55 208 208 WARNING: The logical logs are full. ON-Bar
may encounter errors writing to the sysutils database.
2000-01-16 18:15:36 197 197 F:\\informix\\bin\\onbar_d -b
2000-01-16 18:15:36 197 197 Begin backup logical log 1.
2000-01-16 18:15:38 197 197 Successfully connected to Storage Manager.
2000-01-16 18:15:38 197 197 XBSA Error (BSACreateObject): A system error
occurred. Aborting XBSA session.
2000-01-16 18:15:38 197 197 WARNING: The logical logs are full. ON-Bar
may encounter errors writing to the sysutils database.
2000-01-16 18:16:20 197 197 SQL -25580 System error occurred in network
function.
2000-01-16 18:16:20 197 197 ISAM 54 Connection reset by peer
2000-01-16 18:17:42 197 197 SQL -349 Database not selected yet.