OT: Re: ER error defining template
Posted in 2006
OK, maybe not totally off topic. Last week I've had somewhat similar
situation. Here are the details.
ER setup in primary-target scenario.
HP-UX B.11.23 ia64 + IDS 10.00.FC4
Solaris 9 (Sparc) + IDS 10.00.FC4X5
Customer tried to "cdr check" the replicates (checksum routines successfully
registered before that).
But, on some tables it fails with the next message:
$ cdr check replicate -m g_hzzotest -r repl_idenos_1_10 g_epra -vError at line:4273 - Select index parts for zoroh.idenos
***ABORTING***
Segmentation fault (core dumped)
Same error with "cdr sync" on the same replicate. It doesn't matter if the
command is run on primary instance or the target.
I tried to reproduce the behavior on Linux (on Intel x86), but everything's
OK there, I can't reproduce it (I don't have HP or Sun machine to play
with).
It always reproduces on HP-UX and Solaris.
There are other tables in the same database which fail the same way too. The
rest of the tables succeed.
And now the similarity with this post's problem: tables that fail have
unique indexes created before PK constraints that use them are added.
For example, the schema (only the relevant part) for table in question
(idenos) is:
create table "zoroh".idenos
(
jmbg char(13) not null ,
zdrmb char(9),
...
);
create unique index "informix".idenos_3 on "zoroh".idenos (zdrmb) using
btree ;
alter table "zoroh".idenos add constraint primary key (zdrmb);
Laurie's table also has user-defined unique index which gets used when PK is
added. Maybe that could be the cause.
Thanks
P.S. I have those core dumps available if needed.