Re: error 952 in sqlexecd with SE 7.24 ond SuSE 9.3
Posted in 2005
Hi, more likely I would guess the reason is the use of a password encryption method that is not supported by SE. SE only supports authentication with passwords encrypted by the normal "crypt" (UNIX system call) method. It does not support things like MD5, blowfish, etc. If you want to support password encryption methods other than the normal UNIX "crypt", you have to use IDS (9.40.UC2 or later) and configure it to use PAM (and provide the respective PAM library). To my knowledge SE cannot make use of PAM. Regards, Martin -- Martin Fuerderer IBM Informix Development Munich, Germany Information Management owner-informix-list@iiug.org wrote on 08.06.2005 08:15:29: > Hi, > > i have the following problem: > With SE 7.24 and Linux SuSE 9.3 > the sqlexecd daemon raises the informix error -952 > when a remote database connection is initiated. > With SuSE 8.2 everything works. > I have analyzed that sqlexecd uses different shared libraries in these > two OS releases: > > SuSE 9.3: > /lib/libNoVersion.so.1 (0x40018000) > linux-gate.so.1 => (0xffffe000) > libm.so.6 => /lib/tls/libm.so.6 (0x40031000) > libcrypt.so.1 => /lib/libcrypt.so.1 (0x40054000) > libc.so.6 => /lib/tls/libc.so.6 (0x40086000) > /lib/ld-linux.so.2 (0x40000000) > > SuSE 8.2: > /lib/libNoVersion.so.1 => /lib/libNoVersion.so.1 (0x40015000) > libm.so.6 => /lib/libm.so.6 (0x40025000) > libcrypt.so.1 => /lib/libcrypt.so.1 (0x40048000) > libc.so.6 => /lib/libc.so.6 (0x40079000) > /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000) > > I think the error is caused by an incompatibility of sqlexecd with one > of the shared libs in SuSE 9.3 but i have no further information about these > libs and the authentication process in sqlexecd. > Has anyone more information? > > Thanks in advance > > Klaus Faszl > > Thanks for any help > faszl sending to informix-list