unstable server
Posted in 2011
Topics: Installation, Setup & Upgrades, Connectivity: ODBC / JDBC / .NET
I have one Windows 2008 server running 11.70.TC1IE that requires a restart 2-5 times a day. The web service (IIS) and all com objects and other programs and my services are running on the same server. The ODBC driver is the one from the bundle. The trouble seems to begin with this error: “Desc:[Informix][Informix ODBC Driver] General error.Not enough space for parser stacks Src:Microsoft OLE DB Provider for ODBC Drivers Info: Message:'IDispatch error #3092' “ It can occur in any program.Then IDS refuses all connections. I have increased STACKSIZE to 256 and the problem persists. Is there anyway to find out what is causing this? Would the “parser stacks” be some stacks inside ODBC driver or IIS? The customer is afraid for me to install TC3IE until their busy season is over or I would have done that already.
That error appears to be generated in the ODBC driver not in the IDS server ([Informix][Informix ODBC Driver]) so changes in the engine side wouldn't make much difference. That problem usually appears when the SQL parser inside the ODBC driver gets out of memory. You can try disable the SQL parsing with the SKIPPARSING option: http://publib.boulder.ibm.com/infocenter/idshelp/v117/topic/com.ibm.odbc.doc/ids_odbc_044.htm Still, I suggest to move to the latest 3.70.TC3, it contains more bug fixes than plain TC1