RE: Unable to attach to shared memory
Posted in 2001
Topics: Backup & Restore, Server Administration, Security, Permissions & Auditing, Versions, Editions & End-of-Life
If that is the case, then I would suggest checking permissions on the
distribution files. There is a script at
http://www.iiug.org/software/index_DBA.html called ckfls which will verify
permissions against the distribution list found in $INFORMIXDIR/etc (e.g.
onlinefiles) Print a message whenever it finds a mismatch.
Looking at the script I see it has a hardcoded /usr/informix instead of
$INFORMIXDIR in it - might want to change that.
cheers
j.
> -----Original Message-----
> From: Leon Pappadopoulos [mailto:leon@nja.co.za]
> Sent: Tuesday, February 06, 2001 11:58 AM
> To: informix-list@iiug.org
> Subject: Re: Unable to attach to shared memory
>
>
> Hi
>
> I had a similar experience at client runing on unixware 7
> where someone
> got hold of the root password and felt that it was a good
> idea to change
> all the ownerships
> of the $INFORMIXDIR/bin to root. Fortunately there was
> another machine
> nearby that had all the original settings...
>
> I'm not sure if this is what is causing errors on your
> machine but it's
> almost a mirror
> image of what I found
>
> Hope this helps
>
> Leon Pappadopoulos
> NJA Computer Company
>
> jayachtee@my-deja.com wrote:
>
> > After booting my SCO OpenServer 5.0.6 with IDS 7.30, all is well as
> > long as you are "root". However, if you log in as
> "informix" you get
> > the following message in onmonitor attempting any command. If you
> > perform a total SHUTDOWN of IDS from "root" and start it
> > under "informix", then all works as designed and "root" can do stuff
> > too! BTW, shared memory has the same owners and groups if
> started by
> > user informix but different IDs. Client connections work
> fine as well
> > as ontape. onstat get the "permission denied" stuff, too!
> >
> > Does anyone have a clue why this peculiar behavior exists
> and what is
> > the prescribed cure?
> >
> > ONMONITOR messages:
> > -------------------
> > Unable to attach to shared memory.
> > Permission denied
> >
> > IPCS messages:
> > --------------
> > IPC status from /dev/kmem as of Mon Feb 5 16:18:43 2001
> > T ID KEY MODE OWNER GROUP
> > Shared Memory:
> > m 0 0x52564801 --rw-rw---- root informix
> > m 1 0x52564802 --rw-rw---- root informix
> > m 2 0x52564803 --rw-rw-rw- root informix
> > m 3 0x52564804 --rw-rw-rw- root informix
> > m 4 0x000018e5 --rw-rw-rw- root sys
> > m 5 0x000029f9 --rw------- root root
> >
> > Sent via Deja.com
> > http://www.deja.com/
>
Just downloaded the script "ckfls" and once cut etc and run I get the
following :-
ls: 0653-341 The file /usr/informix/(\\036 does not exist.
Where \\036 is in octal and equivalent to hex 1E or Decimal 30
This resultant control character has the effect of homing the cursor.
Yours
--
Earle A Long (Senior DBA)
SinglePoint Limited
"Parker, Jack" <JParker@engage.com> wrote in message
news:95pnoe$stf$1@news.xmission.com...
>
>
> If that is the case, then I would suggest checking permissions on the
> distribution files. There is a script at
> http://www.iiug.org/software/index_DBA.html called ckfls which will verify
> permissions against the distribution list found in $INFORMIXDIR/etc (e.g.
> onlinefiles) Print a message whenever it finds a mismatch.
>
> Looking at the script I see it has a hardcoded /usr/informix instead of
> $INFORMIXDIR in it - might want to change that.
>
> cheers
> j.
>
> > -----Original Message-----
> > From: Leon Pappadopoulos [mailto:leon@nja.co.za]
> > Sent: Tuesday, February 06, 2001 11:58 AM
> > To: informix-list@iiug.org
> > Subject: Re: Unable to attach to shared memory
> >
> >
> > Hi
> >
> > I had a similar experience at client runing on unixware 7
> > where someone
> > got hold of the root password and felt that it was a good
> > idea to change
> > all the ownerships
> > of the $INFORMIXDIR/bin to root. Fortunately there was
> > another machine
> > nearby that had all the original settings...
> >
> > I'm not sure if this is what is causing errors on your
> > machine but it's
> > almost a mirror
> > image of what I found
> >
> > Hope this helps
> >
> > Leon Pappadopoulos
> > NJA Computer Company
> >
> > jayachtee@my-deja.com wrote:
> >
> > > After booting my SCO OpenServer 5.0.6 with IDS 7.30, all is well as
> > > long as you are "root". However, if you log in as
> > "informix" you get
> > > the following message in onmonitor attempting any command. If you
> > > perform a total SHUTDOWN of IDS from "root" and start it
> > > under "informix", then all works as designed and "root" can do stuff
> > > too! BTW, shared memory has the same owners and groups if
> > started by
> > > user informix but different IDs. Client connections work
> > fine as well
> > > as ontape. onstat get the "permission denied" stuff, too!
> > >
> > > Does anyone have a clue why this peculiar behavior exists
> > and what is
> > > the prescribed cure?
> > >
> > > ONMONITOR messages:
> > > -------------------
> > > Unable to attach to shared memory.
> > > Permission denied
> > >
> > > IPCS messages:
> > > --------------
> > > IPC status from /dev/kmem as of Mon Feb 5 16:18:43 2001
> > > T ID KEY MODE OWNER GROUP
> > > Shared Memory:
> > > m 0 0x52564801 --rw-rw---- root informix
> > > m 1 0x52564802 --rw-rw---- root informix
> > > m 2 0x52564803 --rw-rw-rw- root informix
> > > m 3 0x52564804 --rw-rw-rw- root informix
> > > m 4 0x000018e5 --rw-rw-rw- root sys
> > > m 5 0x000029f9 --rw------- root root
> > >
> > > Sent via Deja.com
> > > http://www.deja.com/
> >
>