11.70.FC7W2 on AIX - dbschema not backward compati
Posted in 2013
Topics: Installation, Setup & Upgrades, Storage & Space Management, Error Codes & Troubleshooting, Server Administration, Security, Permissions & Auditing, Platform-Specific Issues, Versions, Editions & End-of-Life
We have a machine that we allow our users to log in and interface with various
Informix servers, all on AIX. We upgraded the software on that machine to
11.70.FC7W2 and now if a user tries to use dbschema pointing to a server that
is running 11.50.FC9, we get this error: Any ideas??
dbschema -d class -t sysdev -ss -p all
DBSCHEMA Schema Utility INFORMIX-SQL Version 11.70.FC7W2
grant dba to "informix";
-727 - Invalid or NULL TBLspace number given to dbinfo(dbspace).
-130 - ISAM error: no such DBspace
This is due to changes in the system catalog tables between versions. Get
my dbschema replacement utility, myschema, which will work for ALL informix
versions from 5.07 through 12.10!
FYI, I uploaded a new release this past weekend which has some bug fixed
related to triggers that may not have been installed yet. If you run into
any problems with trigger text being line wrapped in the middle of quoted
strings, either run it with --wrap-at=-1 or email me for the latest
release. The README.1st file should have a July date at the top if it is
the latest.
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on my employer, Advanced DataTools, the IIUG, nor any
other organization with which I am associated either explicitly,
implicitly, or by inference. Neither do those opinions reflect those of
other individuals affiliated with any entity with which I am affiliated nor
those of the entities themselves.
On Wed, Jul 17, 2013 at 8:41 AM, Plugge, Joe R. <JRPlugge@west.com> wrote:
> We have a machine that we allow our users to log in and interface with
> various
> Informix servers, all on AIX. We upgraded the software on that machine to
> 11.70.FC7W2 and now if a user tries to use dbschema pointing to a server
> that
> is running 11.50.FC9, we get this error: Any ideas??
>
> dbschema -d class -t sysdev -ss -p all>
> DBSCHEMA Schema Utility INFORMIX-SQL Version 11.70.FC7W2
> grant dba to "informix";>
> -727 - Invalid or NULL TBLspace number given to dbinfo(dbspace).
> -130 - ISAM error: no such DBspace
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--e89a8f50289430f15104e1b4923d