Storage pool is out of space error
Posted in 2013
Topics: Installation, Setup & Upgrades, Storage & Space Management, Third-Party Tools & Monitoring
Hi all, I've recently inherited an Informix database, so I'm relatively new to IDS. Today I got at email telling me: Warning: The storage pool is out of space. To enable automatic chunk creation use the OpenAdmin Tool to add space to the pool. Our main databases have extendable chunks and they seem to be growing OK. We don't have any storage pool entries defined. Am I correct in thinking that this warning could only have been caused by one of the non-expandable dbs's becoming full and wanting to allocate a new chunk from the non-existent storage pool? Also, I noticed that SP_THRESHOLD is set to 0, from what I have read that should prevent the chunks from growing, but our database is now using easily 4x the space it was when it was installed with no apparent problems. Will the chunks just growing when they hit 100% even with this set to 0? Is there any benefit on setting SP_THRESHOLD to say 5 if we aren't using storage pools? Thanks, Michael
Hi, we have this sometimes when a temp DBS runs out of space (for a huge sort operation). When looking at the DB a moment (couple of minutes) later, none of the DBS is really full. The user will get an error (or the system continues the sort operation by using the filesystem, not sure), and afterwards everything is clean again. Action would be to check the huge query or to increase temp spaces. Marcus Haarmann ----- Ursprüngliche Mail ----- Von: "MICHAEL HEYDON" <michael.heydon@jasonwindows.com.au> An: ids@iiug.org Gesendet: Donnerstag, 18. Juli 2013 07:42:04 Betreff: Storage pool is out of space error [30879] Hi all, I've recently inherited an Informix database, so I'm relatively new to IDS. Today I got at email telling me: Warning: The storage pool is out of space. To enable automatic chunk creation use the OpenAdmin Tool to add space to the pool. Our main databases have extendable chunks and they seem to be growing OK. We don't have any storage pool entries defined. Am I correct in thinking that this warning could only have been caused by one of the non-expandable dbs's becoming full and wanting to allocate a new chunk from the non-existent storage pool? Also, I noticed that SP_THRESHOLD is set to 0, from what I have read that should prevent the chunks from growing, but our database is now using easily 4x the space it was when it was installed with no apparent problems. Will the chunks just growing when they hit 100% even with this set to 0? Is there any benefit on setting SP_THRESHOLD to say 5 if we aren't using storage pools? Thanks, Michael ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.